incubator-sling-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From conflue...@apache.org
Subject [CONF] Apache Sling > Towards Sling 6
Date Fri, 30 Jul 2010 17:12:00 GMT
<html>
<head>
    <base href="https://cwiki.apache.org/confluence">
            <link rel="stylesheet" href="/confluence/s/1810/9/1/_/styles/combined.css?spaceKey=SLING&amp;forWysiwyg=true"
type="text/css">
    </head>
<body style="background: white;" bgcolor="white" class="email-body">
<div id="pageContent">
<div id="notificationFormat">
<div class="wiki-content">
<div class="email">
    <h2><a href="https://cwiki.apache.org/confluence/display/SLING/Towards+Sling+6">Towards
Sling 6</a></h2>
    <h4>Page <b>edited</b> by             <a href="https://cwiki.apache.org/confluence/display/~fmeschbe">Felix
Meschberger</a>
    </h4>
        <br/>
                         <h4>Changes (2)</h4>
                                 
    
<div id="page-diffs">
            <table class="diff" cellpadding="0" cellspacing="0">
            <tr><td class="diff-snipped" >...<br></td></tr>
            <tr><td class="diff-unchanged" >|org.apache.sling.jcr.jackrabbit.server|2.0.7-SNAPSHOT|
| <br>|org.apache.sling.jcr.jackrabbit.usermanager|2.0.5-SNAPSHOT| | <br></td></tr>
            <tr><td class="diff-deleted-lines" style="color:#999;background-color:#fdd;text-decoration:line-through;">|org.apache.sling.jcr.ocm|2.0.4-incubator|
| <br></td></tr>
            <tr><td class="diff-unchanged" >|org.apache.sling.jcr.resource|2.0.7-SNAPSHOT|
| <br>|org.apache.sling.jcr.webconsole|1.0.0-SNAPSHOT| | <br></td></tr>
            <tr><td class="diff-snipped" >...<br></td></tr>
            <tr><td class="diff-unchanged" >|org.apache.sling.commons.osgi|2.0.6|
<br>|org.apache.sling.extensions.threaddump|0.2.0| <br></td></tr>
            <tr><td class="diff-added-lines" style="background-color: #dfd;">|org.apache.sling.jcr.ocm|2.0.4-incubator|
<br></td></tr>
        </table>
</div>                            <h4>Full Content</h4>
                    <div class="notificationGreySide">
        <p>A full Sling release is long overdue with the last full release Sling 5 dating
back to May 2009. A number of bundles have been released independently in the mean time and
much work has again been done around the core Sling API.</p>

<p>Taken from the current definition of what's part of a full Sling build found in the
<a href="http://svn.apache.org/repos/asf/sling/trunk/launchpad/builder/src/main/bundles/list.xml"
class="external-link" rel="nofollow">bundle list in the Launchpad Builder project</a>
here is a list of bundles currently (Revision 980813) referenced in the list and whether an
upgrade to a more recent version is desired for Sling 6.</p>

<p>The following is a list of Sling Bundles, which are currently referred to as SNAPSHOT
and require a release for Sling 6:</p>

<div class='table-wrap'>
<table class='confluenceTable'><tbody>
<tr>
<td class='confluenceTd'>Artifact</td>
<td class='confluenceTd'>Current Version</td>
<td class='confluenceTd'>Remark</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.adapter</td>
<td class='confluenceTd'>2.0.4</td>
<td class='confluenceTd'> Trunk has a minor stability fix --&gt; Release/Update
</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.api</td>
<td class='confluenceTd'>2.0.9-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.bundleresource.impl</td>
<td class='confluenceTd'>2.0.4-incubator</td>
<td class='confluenceTd'> Release for new Resource API </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.commons.classloader</td>
<td class='confluenceTd'>1.1.5-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.commons.auth</td>
<td class='confluenceTd'>0.9.0-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.commons.classloader</td>
<td class='confluenceTd'>1.1.5-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.commons.json</td>
<td class='confluenceTd'>2.0.5-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.commons.log</td>
<td class='confluenceTd'>2.0.7-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.engine</td>
<td class='confluenceTd'>2.0.7-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.extensions.groovy</td>
<td class='confluenceTd'>1.0.0-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.extensions.webconsolebranding</td>
<td class='confluenceTd'>0.0.1-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.fsresource</td>
<td class='confluenceTd'>1.0.1-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.httpauth</td>
<td class='confluenceTd'>2.0.5-SNAPSHOT</td>
<td class='confluenceTd'> Remove from Sling 6, HTTP BASIC Authentication has been integrated
into Commons Auth </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.jcr.api</td>
<td class='confluenceTd'>2.0.7-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.jcr.base</td>
<td class='confluenceTd'>2.0.7-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.jcr.classloader</td>
<td class='confluenceTd'>3.1.1-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.jcr.contentloader</td>
<td class='confluenceTd'>2.0.7-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.jcr.davex</td>
<td class='confluenceTd'>0.9.0-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.jcr.jackrabbit.accessmanager</td>
<td class='confluenceTd'>2.0.5-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.jcr.jackrabbit.server</td>
<td class='confluenceTd'>2.0.7-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.jcr.jackrabbit.usermanager</td>
<td class='confluenceTd'>2.0.5-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.jcr.resource</td>
<td class='confluenceTd'>2.0.7-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.jcr.webconsole</td>
<td class='confluenceTd'>1.0.0-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.jcr.webdav</td>
<td class='confluenceTd'>2.0.9-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.launchpad.base</td>
<td class='confluenceTd'>2.2.1-SNAPSHOT</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.launchpad.content</td>
<td class='confluenceTd'>2.0.5-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.openidauth</td>
<td class='confluenceTd'>0.9.1-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.scripting.api</td>
<td class='confluenceTd'>2.1.0</td>
<td class='confluenceTd'> Trunk has fix for SLING-1510 --&gt; Release/Update </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.scripting.core</td>
<td class='confluenceTd'>2.0.11-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.scripting.javascript</td>
<td class='confluenceTd'>2.0.6</td>
<td class='confluenceTd'> Trunk has a fix in preserving scope --&gt; Release/Update
</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.scripting.jsp</td>
<td class='confluenceTd'>2.0.9-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.scripting.jsp.taglib</td>
<td class='confluenceTd'>2.0.7-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.servlets.get</td>
<td class='confluenceTd'>2.0.9-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.servlets.post</td>
<td class='confluenceTd'>2.0.5-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.servlets.resolver</td>
<td class='confluenceTd'>2.0.9-SNAPSHOT</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
</tbody></table>
</div>




<p>Artifacts included in Sling 6 from outside the Sling project:</p>

<div class='table-wrap'>
<table class='confluenceTable'><tbody>
<tr>
<td class='confluenceTd'>Artifact</td>
<td class='confluenceTd'>Current Version</td>
<td class='confluenceTd'>Remark</td>
</tr>
<tr>
<td class='confluenceTd'>commons-fileupload</td>
<td class='confluenceTd'>1.2.1</td>
<td class='confluenceTd'> Upgrade to 1.2.2 (just released) ? </td>
</tr>
<tr>
<td class='confluenceTd'>commons-lang</td>
<td class='confluenceTd'>2.4</td>
<td class='confluenceTd'> upgrade to 2.5 ? See <a href="http://commons.apache.org/lang/upgradeto2_5.html"
class="external-link" rel="nofollow">release notes for 2.5</a> </td>
</tr>
<tr>
<td class='confluenceTd'>derby</td>
<td class='confluenceTd'>10.5.3.0_1</td>
<td class='confluenceTd'> Upgrade to Derby 10.6.1.0 ? See <a href="http://old.nabble.com/-ANNOUNCE--Apache-Derby-10.6.1.0-released-td28610453.html"
class="external-link" rel="nofollow">release notes</a> </td>
</tr>
<tr>
<td class='confluenceTd'>groovy-all</td>
<td class='confluenceTd'>1.7.0</td>
<td class='confluenceTd'> Upgrade to most recent stable release 1.7.4 ? </td>
</tr>
<tr>
<td class='confluenceTd'>tika-bundle</td>
<td class='confluenceTd'>0.6</td>
<td class='confluenceTd'> Upgrade to Tika 0.6 ? See <a href="http://tika.apache.org/0.7/index.html"
class="external-link" rel="nofollow">release notes</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.felix.http.whiteboard</td>
<td class='confluenceTd'>2.0.4</td>
<td class='confluenceTd'> Related to Apache Felix HTTP support contained in the Launchpad
Base module. There have been a few updates to Apache Felix HTTP trunk. Should we update ?
</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.felix.webconsole</td>
<td class='confluenceTd'>3.0.0</td>
<td class='confluenceTd'> A number of fixes in trunk --&gt; Plan to release and
update </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.felix.webconsole.plugins.event</td>
<td class='confluenceTd'>1.0.2</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.felix.webconsole.plugins.memoryusage</td>
<td class='confluenceTd'>1.0.0</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.felix.bundlerepository</td>
<td class='confluenceTd'>1.4.0</td>
<td class='confluenceTd'> Upgrade to late</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.felix.eventadmin</td>
<td class='confluenceTd'>1.0.0</td>
<td class='confluenceTd'> Upgrade to EventAdmin 1.2.2 containing lots of stability fixes
</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.felix.scr</td>
<td class='confluenceTd'>1.4.0</td>
<td class='confluenceTd'> A number of fixes in trunk --&gt; Plan to release and
update </td>
</tr>
</tbody></table>
</div>




<p>The following dependencies listed in <tt>list.xml</tt> are current versions
or have been decided to not require and update and are ready for use in Sling 6:</p>

<div class='table-wrap'>
<table class='confluenceTable'><tbody>
<tr>
<td class='confluenceTd'>Artifact</td>
<td class='confluenceTd'>Version</td>
</tr>
<tr>
<td class='confluenceTd'>commons-io</td>
<td class='confluenceTd'>1.4</td>
</tr>
<tr>
<td class='confluenceTd'>commons-collections</td>
<td class='confluenceTd'>3.2.1</td>
</tr>
<tr>
<td class='confluenceTd'>jackrabbit-api</td>
<td class='confluenceTd'>2.1.0</td>
</tr>
<tr>
<td class='confluenceTd'>jackrabbit-jcr-commons</td>
<td class='confluenceTd'>2.1.0</td>
</tr>
<tr>
<td class='confluenceTd'>jackrabbit-spi</td>
<td class='confluenceTd'>2.1.0</td>
</tr>
<tr>
<td class='confluenceTd'>jackrabbit-spi-commons</td>
<td class='confluenceTd'>2.1.0</td>
</tr>
<tr>
<td class='confluenceTd'>jackrabbit-jcr-rmi</td>
<td class='confluenceTd'>2.1.0</td>
</tr>
<tr>
<td class='confluenceTd'>jcr</td>
<td class='confluenceTd'>2.0</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.aries.jmx.api</td>
<td class='confluenceTd'>0.1-incubating</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.aries.jmx.core</td>
<td class='confluenceTd'>0.1-incubating</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.felix.configadmin</td>
<td class='confluenceTd'>1.2.4</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.felix.metatype</td>
<td class='confluenceTd'>1.0.4</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.commons.mime</td>
<td class='confluenceTd'>2.1.4</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.commons.osgi</td>
<td class='confluenceTd'>2.0.6</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.extensions.threaddump</td>
<td class='confluenceTd'>0.2.0</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.jcr.ocm</td>
<td class='confluenceTd'>2.0.4-incubator</td>
</tr>
</tbody></table>
</div>

    </div>
        <div id="commentsSection" class="wiki-content pageSection">
        <div style="float: right;">
            <a href="https://cwiki.apache.org/confluence/users/viewnotifications.action"
class="grey">Change Notification Preferences</a>
        </div>
        <a href="https://cwiki.apache.org/confluence/display/SLING/Towards+Sling+6">View
Online</a>
        |
        <a href="https://cwiki.apache.org/confluence/pages/diffpagesbyversion.action?pageId=23333743&revisedVersion=3&originalVersion=2">View
Changes</a>
                |
        <a href="https://cwiki.apache.org/confluence/display/SLING/Towards+Sling+6?showComments=true&amp;showCommentArea=true#addcomment">Add
Comment</a>
            </div>
</div>
</div>
</div>
</div>
</body>
</html>

Mime
View raw message