incubator-sanselan-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Charles Matthew Chen" <charlesmc...@gmail.com>
Subject Re: About sanselan on JRE 1.3
Date Sun, 13 Jan 2008 20:11:57 GMT
Hi Eric,

   I've just successfully ported the current state of Sanselan (from
the apache repo) back to Java 1.3 (specifically, the 1.3.1.20 SDK).

   Incidentally, the Java 1.31 SDK has been end-of-lifed by sun.  You
can download it here:
http://java.sun.com/products/archive/

   The old url no longer works:
http://java.sun.com/j2se/1.3/

   Porting required 3-4 minor patches and shouldn't entail any loss of
functionality.

   There still isn't an Apache build available yet; I intend to
release another non-apache build in the next week.  That is, I based
the back-ported version on code that hasn't been officially released
yet, but will be soon.  I've uploaded the backward-ported Sanselan as:

http://www.fightingquaker.com/sanselan/sanselan-1.3-src.zip

   It's a source-only release.  I don't intend to maintain this
version of the code.  1.3 is EOL'd, and there really isn't anyone else
clamoring for this.  The unit tests may not work; I didn't test them.

   I hope you find this helpful.  Please let me know if you have any
questions or problems.

Charles.

I've cc'd the sanselan development list.



On Jan 10, 2008 5:15 PM, Eric Liao <ericshliao@gmail.com> wrote:
> Hi,
> I am looking for a Java image lib compatible with JRE1.3 and I found
> Sanselan.
> The webpage says that "Sanselan requires Java 1.4 or higher. It could easily
> be converted to require only 1.2. "
> I tried to compile with jdk1.3 and encountered several errors.
> I wonder if these error can be coped with by adjusting compile options or
> modification of source code is required.
>
> Sincerely,
>
> Eric

Mime
View raw message