incubator-s4-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rujuta Deshpande <rujd...@gmail.com>
Subject -p option not found in the ./s4 deploy list of options
Date Sat, 07 Sep 2013 15:08:38 GMT
Hi,

I am a new user of Apache S4 and am trying to run the first HelloApp
application on my system. I have done a checkout from the Apache git
repository.

When trying to follow the 'walkthrough' for the first application,
everything works fine until this step :

./s4 deploy -appClass=hello.HelloInputAdapter
-p=s4.adapter.output.stream=names -c=cluster2 -appName=adapter


I get this error:

*calling referenced s4 script : /home/XYZ/YZD/git_apaches4/incubator-s4/s4*
*Cannot parse arguments: class com.beust.jcommander.ParameterException
-> Unknown
option: -p=s4.adapter.output.stream=names*
*Usage: <main class> [options]*
*  Options:*
*    -a, -appClass       Full class name of the application class
(extending App*
*                        or AdapterApp)*
*  * -appName            Name of S4 application.*
*    -b, -buildFile      Full path to gradle build file for the S4
application*
*  * -c, -cluster        Logical name of the S4 cluster*
*    -generatedS4R, -g   Location of generated s4r (incompatible with -s4r*
*                        option). By default, s4r is generated in a
temporary directory on*
*                        the local file system. In a distributed
environment, you*
*                        probably want to specify a location accessible
through a*
*                        distributed file system like NFS. That's the
purpose of this option.*
*    -gradleOpts         gradle system properties (as in GRADLE_OPTS
environment*
*                        properties) passed to gradle scripts*
*                        Default: []*
*    -help               usage*
*                        Default: false*
*    -s4r                Path to existing s4r file*
*    -timeout            Connection timeout to Zookeeper, in ms*
*                        Default: 10000*
*    -zk                 ZooKeeper connection string*
*                        Default: localhost:2181*


As can be seen from above, there is not option of -p and I'm stumped about
how to proceed now.

It will be great if someone can point out any possible reason as to why
this has happened.

Thanks,
R

Mime
View raw message