incubator-s4-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "唐装鼠" <654125...@qq.com>
Subject jni error
Date Mon, 08 Jul 2013 08:42:41 GMT
Hi,it looks like S4 has problem when loading libraries.
I use JNI in my project.When call the native method,errors come out as below:


16:31:52.626 [atos] ERROR org.apache.s4.core.S4Node - Uncaught exception in thread atos
java.lang.UnsatisfiedLinkError: hello.Shellcode.checkShellcode(Ljava/lang/String;)V
    at hello.Shellcode.checkShellcode(Native Method) ~[qqApp.jar:unspecified]
    at hello.ShellcodeCheckPE.onEvent(ShellcodeCheckPE.java:106) ~[qqApp.jar:unspecified]
    at OverloadDispatcher709.dispatchEvent(Unknown Source) ~[na:na]
    at org.apache.s4.core.ProcessingElement.handleInputEvent(ProcessingElement.java:461) ~[s4-core-0.6.0-incubating.jar:0.6.0-incubating]
    at org.apache.s4.core.Stream$StreamEventProcessingTask.run(Stream.java:333) ~[s4-core-0.6.0-incubating.jar:0.6.0-incubating]
    at org.apache.s4.comm.staging.BlockingThreadPoolExecutorService$RunnableWithPermitRelease.run(BlockingThreadPoolExecutorService.java:178)
~[s4-comm-0.6.0-incubating.jar:0.6.0-incubating]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) ~[na:1.7.0_25]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) ~[na:1.7.0_25]
    at java.lang.Thread.run(Thread.java:724) ~[na:1.7.0_25]



Could anyone help me?
Mime
View raw message