incubator-s4-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "唐装鼠" <654125...@qq.com>
Subject NoClassDefFoundError
Date Wed, 05 Jun 2013 09:10:10 GMT
Hi,I build a java project.when it runs in cluster of 4 nodes,only one node works well while
the other 3 nodes runs with below error:


 02:04:04.894 [itoa] ERROR org.apache.s4.core.S4Node - Uncaught exception in thread itoa
java.lang.NoClassDefFoundError: Could not initialize class org.jnetpcap.packet.PcapPacket
        at hello.AbstractPE.onEvent(AbstractPE.java:53) ~[fishApp.jar:unspecified]
        at OverloadDispatcher2409.dispatchEvent(Unknown Source) ~[na:na]
        at org.apache.s4.core.ProcessingElement.handleInputEvent(ProcessingElement.java:461)
~[s4-core-0.6.0-incubating.jar:0.6.0-incubating]
        at org.apache.s4.core.Stream$StreamEventProcessingTask.run(Stream.java:333) ~[s4-core-0.6.0-incubating.jar:0.6.0-incubating]
        at org.apache.s4.comm.staging.BlockingThreadPoolExecutorService$RunnableWithPermitRelease.run(BlockingThreadPoolExecutorService.java:178)
~[s4-comm-0.6.0-incub
ating.jar:0.6.0-incubating]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
~[na:1.7.0_17]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
~[na:1.7.0_17]
        at java.lang.Thread.run(Thread.java:722) ~[na:1.7.0_17]




The .jar file which includes PcapPacket class  is exactly in the lib directory.However,it
still says NoClassDefFoundError.
I guess java configuration is wrong in the other 3 machines.But I don't konw where is wrong
exactly.Can someone help me?
Thanks very much.
Mime
View raw message