incubator-s4-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthieu Morel <mmo...@apache.org>
Subject Re: can anyone help me please
Date Mon, 27 May 2013 13:53:03 GMT
I already replied on the dev list, but for the record (and note it is better to use s4-user
for this kind of questions):

S4 does not clean up metadata stored in ZooKeeper. You need to do that manually between runs.
Either by restarting with a clean ZooKeeper ensemble, or with ZooKeeper tools such as "rmr
/s4" (rmr is available from zookeeper 3.4.5 I think).

Hope this helps,

Matthieu


On May 27, 2013, at 15:48 , baojian Zhou wrote:

> i start test the s4 benchmark application, and then run the ./bench-cluster.sh command
then i got this error :
> 
>  21:23:18.570 [main] INFO  org.apache.s4.tools.ZKServer - Zookeeper server started on
port [2181]
> 21:23:18.618 [main] INFO  org.apache.s4.tools.ZKServer - Defined S4 cluster [testCluster1]
with [0] tasks with first listening port [12000]
> 21:23:18.706 [main] ERROR org.apache.s4.tools.ZKServer - Cannot initialize zookeeper
with specified configuration
> org.I0Itec.zkclient.exception.ZkNodeExistsException: org.apache.zookeeper.KeeperException$NodeExistsException:
KeeperErrorCode = NodeExists for /s4/clusters/testCluster2/tasks/Task-0
>         at org.I0Itec.zkclient.exception.ZkException.create(ZkException.java:55) ~[zkclient-0.1.jar:na]
>         at org.I0Itec.zkclient.ZkClient.retryUntilConnected(ZkClient.java:685) ~[zkclient-0.1.jar:na]
>         at org.I0Itec.zkclient.ZkClient.create(ZkClient.java:304) ~[zkclient-0.1.jar:na]
>         at org.I0Itec.zkclient.ZkClient.createPersistent(ZkClient.java:243) ~[zkclient-0.1.jar:na]
>         at org.apache.s4.comm.tools.TaskSetup.setup(TaskSetup.java:69) ~[s4-comm-0.6.0-incubating.jar:0.6.0-incubating]
>         at org.apache.s4.tools.ZKServer.main(ZKServer.java:94) ~[s4-tools-0.6.0-incubating.jar:0.6.0-incubating]
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[na:1.6.0_20]
>         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
~[na:1.6.0_20]
>         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
~[na:1.6.0_20]
>         at java.lang.reflect.Method.invoke(Method.java:616) ~[na:1.6.0_20]
>         at org.apache.s4.tools.Tools$Task.dispatch(Tools.java:57) [s4-tools-0.6.0-incubating.jar:0.6.0-incubating]
>         at org.apache.s4.tools.Tools.main(Tools.java:97) [s4-tools-0.6.0-incubating.jar:0.6.0-incubating]
> Caused by: org.apache.zookeeper.KeeperException$NodeExistsException: KeeperErrorCode
= NodeExists for /s4/clusters/testCluster2/tasks/Task-0
>         at org.apache.zookeeper.KeeperException.create(KeeperException.java:110) ~[zookeeper-3.3.3.jar:3.3.3-1073969]
>         at org.apache.zookeeper.KeeperException.create(KeeperException.java:42) ~[zookeeper-3.3.3.jar:3.3.3-1073969]
>         at org.apache.zookeeper.ZooKeeper.create(ZooKeeper.java:637) ~[zookeeper-3.3.3.jar:3.3.3-1073969]
>         at org.I0Itec.zkclient.ZkConnection.create(ZkConnection.java:87) ~[zkclient-0.1.jar:na]
>         at org.I0Itec.zkclient.ZkClient$1.call(ZkClient.java:308) ~[zkclient-0.1.jar:na]
>         at org.I0Itec.zkclient.ZkClient$1.call(ZkClient.java:304) ~[zkclient-0.1.jar:na]
>         at org.I0Itec.zkclient.ZkClient.retryUntilConnected(ZkClient.java:675) ~[zkclient-0.1.jar:na]
>         ... 10 common frames omitted
> 
> can anyone tell me why?


Mime
View raw message