incubator-s4-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthieu Morel <mmo...@apache.org>
Subject Re: something wrong when i run benchmark
Date Wed, 29 May 2013 15:06:47 GMT
s4 benchmarks were initially designed to be used on a shared distributed file system without
actually "deploying" apps. Is that your setting? Otherwise, you'll probably need to make the
packaged apps accessible from a remote location like a web server (see the twitter example)
and pass a reference to that when starting the nodes.

Regards,


Matthieu

On May 29, 2013, at 09:37 , baojian Zhou wrote:

> hi everyone , when i run the benchmark use the remote node, i just got the output_node6-1.log,
it contents some errors´╝Ü
> 15:30:27.311 [main] ERROR org.apache.s4.core.S4Node - Uncaught exception in thread main
> java.lang.NoClassDefFoundError: org/apache/commons/logging/Log
>         at org.apache.s4.core.BaseModule.loadProperties(BaseModule.java:78) ~[s4-core-0.6.0-incubating.jar:0.6.0-incubating]
>         at org.apache.s4.core.BaseModule.configure(BaseModule.java:59) ~[s4-core-0.6.0-incubating.jar:0.6.0-incubating]
>         at com.google.inject.AbstractModule.configure(AbstractModule.java:59) ~[guice-3.0.jar:na]
>         at com.google.inject.spi.Elements$RecordingBinder.install(Elements.java:223)
~[guice-3.0.jar:na]
>         at com.google.inject.spi.Elements.getElements(Elements.java:101) ~[guice-3.0.jar:na]
>         at com.google.inject.spi.Elements.getElements(Elements.java:92) ~[guice-3.0.jar:na]
>         at com.google.inject.util.Modules$RealOverriddenModuleBuilder$1.configure(Modules.java:152)
~[guice-3.0.jar:na]
>         at com.google.inject.AbstractModule.configure(AbstractModule.java:59) ~[guice-3.0.jar:na]
>         at com.google.inject.spi.Elements$RecordingBinder.install(Elements.java:223)
~[guice-3.0.jar:na]
>         at com.google.inject.spi.Elements.getElements(Elements.java:101) ~[guice-3.0.jar:na]
>         at com.google.inject.internal.InjectorShell$Builder.build(InjectorShell.java:133)
~[guice-3.0.jar:na]
>         at com.google.inject.internal.InternalInjectorCreator.build(InternalInjectorCreator.java:103)
~[guice-3.0.jar:na]
>         at com.google.inject.Guice.createInjector(Guice.java:95) ~[guice-3.0.jar:na]
>         at com.google.inject.Guice.createInjector(Guice.java:72) ~[guice-3.0.jar:na]
>         at com.google.inject.Guice.createInjector(Guice.java:62) ~[guice-3.0.jar:na]
>         at org.apache.s4.core.S4Node.startNode(S4Node.java:80) ~[s4-core-0.6.0-incubating.jar:0.6.0-incubating]
>         at org.apache.s4.core.S4Node.main(S4Node.java:61) ~[s4-core-0.6.0-incubating.jar:0.6.0-incubating]
> Caused by: java.lang.ClassNotFoundException: org.apache.commons.logging.Log
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:217) ~[na:1.6.0_17]
>         at java.security.AccessController.doPrivileged(Native Method) ~[na:1.6.0_17]
>         at java.net.URLClassLoader.findClass(URLClassLoader.java:205) ~[na:1.6.0_17]
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:319) ~[na:1.6.0_17]
>         at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294) ~[na:1.6.0_17]
>  at java.lang.ClassLoader.loadClass(ClassLoader.java:264) ~[na:1.6.0_17]
>         at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:332) ~[na:1.6.0_17]
>         ... 17 common frames omitted
> 
> but i run the same in a single mode, i think that something wrong about S4Node args;
but i have no idea how to fix it, can any one help me?





Mime
View raw message