incubator-s4-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andriy Pidgurskiy <a.pidgurs...@gmail.com>
Subject Re: Can't run / build S4 - endless waiting on Resolving dependencies ':s4-tools:compile'
Date Mon, 14 Jan 2013 11:49:30 GMT
Matthieu,


thanks for prompt reply.


yes, I am using the 0.5 release

I am not using any proxies on my PC so proxy fix is not valid.


The problem seems to be with google-gson.googlecode.com repository and is
reproducable on fresh PC setup. I've run number of Linuxes on my VirtualBox
- all the same. Probably it is because my setup is new and doesn't have any
libraries at all.

The issue is fixed locally now by replacing repository reference in main
build.gradle from "maven { url '
http://google-gson.googlecode.com/svn/mavenrepo' }"  to
        maven { url 'http://google-gson.googlecode.com/svn/mavenrepo' }
        maven { url 'http://repo.gradle.org/gradle/libs-releases-local' }
        maven { url 'http://repo.jfrog.org/artifactory/repo' }
and updating all subproject's build.gradle

Thanks again for prompt reply.


On Mon, Jan 14, 2013 at 9:20 AM, Matthieu Morel <mmorel@apache.org> wrote:

> Hi Andriy,
>
> I assume you are using the 0.5 release? We can't reproduce that issue, so
> it might be something related to your connectivity to the repositories.
>
> Have you tried the proxy trick on the FAQ page?
> https://cwiki.apache.org/S4/faq.html
>
> Hope this helps,
>
> Matthieu
>
> On Jan 14, 2013, at 04:18 , Andriy Pidgurskiy wrote:
>
> Hello,
>
>
> I've been trying to build / run the S4 platform for last 4 hours and can't
> do that neither on Window 7 nor on Ubuntu
>
> on both systems the "gradlew s4-tools:installApp" command stuck with ">
> Building > :s4-tools:compileJava > Resolving dependencies
> ':s4-tools:compile'" message
>
> enabling debug I can see that it looks for
> http://google-gson.googlecode.com/svn/mavenrepo/org/gradle/gradle-tooling-api/1.0/gradle-tooling-api-1.0.pombut
the URL returns 404 "Not Found"
>
>
> I think it is because the http://google-gson.googlecode.com/svn/mavenrepo/doesn't have
gradle-tooling-api-1.0 library
>
> Would you please advise / update build scripts ?
>
>
> --
> Regards.
> Andriy Pidgurskiy.
>
>
>


-- 
Regards.
Andriy Pidgurskiy.

Mime
View raw message