incubator-s4-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jaime D <100025...@alumnos.uc3m.es>
Subject Re: S4R deployment from a webserver
Date Fri, 14 Dec 2012 20:49:24 GMT
OK, thank you for the info Matthieu. Reported in jira:
https://issues.apache.org/jira/browse/S4-111

Regards,
Jaime

On Fri, Dec 14, 2012 at 8:54 PM, Matthieu Morel <mmorel@apache.org> wrote:
> Hi Jaime,
>
> this looks like a bug in the Deploy tool (fetching from http works, when the s4r file
URI is correct in ZooKeeper, unfortunately that does not seem to work directly when using
the Deploy tool).
>
> If you can file a Jira ticket for that, it would be great!
>
> Thanks,
>
> Matthieu
>
> On Dec 14, 2012, at 08:50 , Jaime D wrote:
>
>> Hello all!
>>
>> I've gone through the examples included in the 0.5.0 release with
>> success! thank you for the available documentation.
>>
>> The only problem I had was trying to deploy the twitter app in a
>> distributed environment. I build the s4r files, leave them in a web
>> server accesible from my machines, and try executing this:
>>
>> ./s4 deploy -s4r=http://<server>/<path>/twitter-adapter.s4r
>> -c=cluster2 -appName=twitter-adapter
>>
>> with the result:
>>
>> 01:15:52.584 [main] ERROR org.apache.s4.tools.Deploy - Specified S4R
>> file does not exist in
>> /home/jaime/s4/http:/<server>/<path>/twitter-adapter.s4r
>>
>> I searched through the mailing list archives and found this thread:
>> http://mail-archives.apache.org/mod_mbox/incubator-s4-user/201207.mbox/%3C4FFE7DA9.9060107@apache.org%3E
>>
>> Passing the url with the -s4r option seems to be right, HTTP protocol
>> is supported in this version, ...
>> Has any of you achieved http deployment? Thank you!
>>
>> Regards,
>> Jaime
>>
>

Mime
View raw message