incubator-s4-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthieu Morel <mmo...@apache.org>
Subject Re: Zookeeper Binding Problems
Date Wed, 08 Aug 2012 08:12:22 GMT
On 8/7/12 8:06 PM, Natacha Crooks wrote:
> No, unfortunately, nothing was running on 12000, I tried on a few other
> ports, but get similar error messages.

Could you modify the source and enclose the bootstrap.bind call in the 
TCPListener, from where the exception is thrown, with something like:

} catch (ChannelException e) {
    logger.error("Channel exception from netty", e.getCause());
    throw e;
}

That should show the root cause of the error.

Matthieu

>
> On 7 August 2012 17:59, Matthieu Morel <mmorel@apache.org
> <mailto:mmorel@apache.org>> wrote:
>
>     On 8/7/12 6:39 PM, Natacha Crooks wrote:
>
>
>         Hi,
>
>         Sorry for posting again, but everything was working well up
>         until today
>         where I have been getting the following error when launching a
>         node . It
>         seemed to happen very suddenly as it was working fine yesterday.
>         I've
>         tried to fix it but to no avail. Any ideas?
>
>
>
>     I'd recommend to:
>     - check that something is not running on port 12000
>     - use the latest version of piper (which most probably will be the
>     first release, we are currently voting on that in the Apache mailing
>     lists).
>
>     Update should be straightforward since you are using a recent
>     version I believe, just note the "s4" prefix is now used for S4
>     platform parameters.
>
>
>     Let us know,
>
>     Thanks,
>
>     Matthieu
>
>
>
>
>
>
>
>         Thank you very much
>
>
>            17:31:01.245 [main] INFO  o.a.s4.comm.topology.__ClusterFromZK -
>         Changing cluster topology to {
>         nbNodes=1,name=cluster1,mode=__unicast,type=,nodes=[{__partition=0,port=12000,__machineName=thegluups-__ThinkPad-X220-Tablet,taskId=__Task-0}]}
>         from null
>         17:31:01.270 [main] ERROR org.apache.s4.core.Server - Could not
>         load s4
>         application form s4r file
>         [{/tmp/deploy-test/cluster1/__MultipleOpsApp.s4r}]
>         com.google.inject.__ProvisionException: Guice provision errors:
>
>         1) Error injecting constructor,
>         org.jboss.netty.channel.__ChannelException: Failed to bind to:
>         0.0.0.0/0.0.0.0:12000 <http://0.0.0.0/0.0.0.0:12000>
>         <http://0.0.0.0/0.0.0.0:12000>
>
>             at
>         org.apache.s4.comm.tcp.__TCPListener.<init>(__TCPListener.java:49)
>             while locating org.apache.s4.comm.tcp.__TCPListener
>             while locating org.apache.s4.base.Listener
>               for parameter 0 at
>         org.apache.s4.core.Receiver.<__init>(Receiver.java:42)
>             at org.apache.s4.core.Receiver.__class(Receiver.java:34)
>             while locating org.apache.s4.core.Receiver
>               for field at org.apache.s4.core.App.__receiver(App.java:42)
>             while locating hello.MultipleOpsApp
>
>         1 error
>         at
>         com.google.inject.internal.__Errors.__throwProvisionExceptionIfError__sExist(Errors.java:451)
>         ~[guice-3.0.jar:na]
>         at
>         com.google.inject.internal.__MembersInjectorImpl.__injectMembers(__MembersInjectorImpl.java:65)
>         ~[guice-3.0.jar:na]
>         at
>         com.google.inject.internal.__InjectorImpl.injectMembers(__InjectorImpl.java:944)
>         ~[guice-3.0.jar:na]
>         at org.apache.s4.core.Server.__loadApp(Server.java:141)
>         [s4-core-0.5.0-SNAPSHOT.jar:0.__5.0-SNAPSHOT]
>
>
>
>
>
> --
> Natacha Crooks
> St John's College, Cambridge
>


Mime
View raw message