incubator-s4-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From JiHyoun Park <apr...@gmail.com>
Subject Re: Running S4 nodes on multiple machines - error
Date Fri, 22 Jun 2012 09:08:42 GMT
Hi,

Thank you!!!!!!!!
You save me.
Sure, I will try Zookeeper and keep trying to get acquainted with S4.
Thank you again.

Best Regards
Jihyoun

On 6/22/12, Mariano Vallés <zucaritas@gmail.com> wrote:
> Hi, The problem might be that your properties file is trying to
> connect dynamically.
> Specifically the line
>> commlayer_mode=dynamic
> Should be:
>> commlayer_mode=static
>
> If you still want to run the cluster with Zookeeper, you might have to
> add the Zookeeper server address when starting the S4 cluster.
> This thread might help you.
> https://groups.google.com/group/s4-project/browse_thread/thread/5610ae8dcb4f78fe/194c64cf642dd43c?pli=1
>
> I hope that helps.
> M.
>
>
> On Fri, Jun 22, 2012 at 9:36 AM, JiHyoun Park <april3@gmail.com> wrote:
>> Hi,
>>
>> I am testing 'Running S4 nodes on multiple machines'.
>>
>> I have 2 hosts: s4test1 and s4test2.
>> According to the guide, I configured my clusters.xml and started an S4
>> node on s4test2 and an S4 node, the adapter and the Twitter feed
>> listener on s4test1.
>>
>> For the s4test1, everything is fine.
>> ==============================================================
>> [root@s4test1 redbutton-multi]# find $S4_IMAGE/s4-core/logs/s4-core
>> -name "s4-core_*.log" -print -exec sh -c 'grep -i "count by" {} | tail
>> -4' \;
>> /usr/local/s4/build/s4-image/s4-core/logs/s4-core/s4-core_5515.log
>> 2012-06-22 15:27:16,792 s4 INFO (PEContainer.java:362) Count by
>> TopicSeen topic: 3420
>> 2012-06-22 15:27:26,796 s4 INFO (PEContainer.java:362) Count by
>> RawStatus : 37052
>> 2012-06-22 15:27:26,797 s4 INFO (PEContainer.java:362) Count by
>> AggregatedTopicSeen : 19157
>> 2012-06-22 15:27:26,797 s4 INFO (PEContainer.java:362) Count by
>> TopicSeen topic: 3438
>> /usr/local/s4/build/s4-image/s4-core/logs/s4-core/s4-core_5654.log
>> ==============================================================
>>
>> However, for the s4test2, I couldn't get any result using the above
>> command. So, I looked into the log file.
>> ==============================================================
>> 2012-06-22 15:15:43,406 org.apache.zookeeper.ClientCnxn INFO
>> (ClientCnxn.java:10
>> 00) Opening socket connection to server localhost/127.0.0.1:2181
>> 2012-06-22 15:15:43,406 org.apache.zookeeper.ClientCnxn WARN
>> (ClientCnxn.java:11
>> 20) Session 0x0 for server null, unexpected error, closing socket
>> connection and
>>  attempting reconnect
>> java.net.ConnectException: Connection refused
>>        at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
>>        at
>> sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:592
>> )
>>        at
>> org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1078)
>> ==============================================================
>>
>> Yesterday, I tried to test 'Running S4 with Zookeeper' but failed.
>> Thus, I decided to test 'Running S4 on multiple machines without
>> Zookeeper' first. But I think maybe something got corrupted.
>>
>> The s4-core.properties-header file of s4test2 is as follows.
>> ==============================================================
>> [root@s4test2 redbutton-multi]# cat s4-core.properties-header
>> gc_opts=-server -XX:+HeapDumpOnOutOfMemoryError
>> -XX:+UseConcMarkSweepGC -XX:-UseGCOverheadLimit
>> mem_opts=-Xms800m -Xmx2000m
>> remote_debug_enabled=no
>> pe_container_max_queue_size=8000
>> listener_max_queue_size=8000
>> commlayer_mode=dynamic
>> zk_session_timeout=5000
>> deamon_mode_enabled=false
>> zk_address=localhost:2181
>> ==============================================================
>>
>> What should I do?
>>
>> Best Regards
>> Jihyoun
>

Mime
View raw message