incubator-s4-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthieu Morel <mmo...@apache.org>
Subject Re: NoNode for /s4/clusters/c1/apps/myApp
Date Fri, 08 Jun 2012 10:22:36 GMT
On 6/8/12 11:17 AM, Qiuzhanbo wrote:
> hi,all
> I test S4 piper follow https://cwiki.apache.org/S4/s4-piper-walkthrough.html step by
step on suse . when Publish the s4r archive ,throw an exception as follows:
> 16:57:27.560 [main] ERROR org.apache.s4.tools.Deploy - Cannot deploy app
> org.I0Itec.zkclient.exception.ZkNoNodeException: org.apache.zookeeper.KeeperException$NoNodeException:
KeeperErrorCode = NoNode for /s4/clusters/c1/apps/myApp
> 	at org.I0Itec.zkclient.exception.ZkException.create(ZkException.java:47) ~[zkclient-0.1.jar:na]
> 	at org.I0Itec.zkclient.ZkClient.retryUntilConnected(ZkClient.java:685) ~[zkclient-0.1.jar:na]
> 	at org.I0Itec.zkclient.ZkClient.create(ZkClient.java:304) ~[zkclient-0.1.jar:na]
> 	at org.apache.s4.tools.Deploy.main(Deploy.java:74) ~[s4-tools-0.5.0-SNAPSHOT.jar:0.5.0-SNAPSHOT]
> 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[na:1.6.0_29]
> 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) ~[na:1.6.0_29]
> 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
~[na:1.6.0_29]
> 	at java.lang.reflect.Method.invoke(Method.java:597) ~[na:1.6.0_29]
> 	at org.apache.s4.tools.Tools$Task.dispatch(Tools.java:34) [s4-tools-0.5.0-SNAPSHOT.jar:0.5.0-SNAPSHOT]
> 	at org.apache.s4.tools.Tools.main(Tools.java:69) [s4-tools-0.5.0-SNAPSHOT.jar:0.5.0-SNAPSHOT]
> Caused by: org.apache.zookeeper.KeeperException$NoNodeException: KeeperErrorCode = NoNode
for /s4/clusters/c1/apps/myApp
> 	at org.apache.zookeeper.KeeperException.create(KeeperException.java:102) ~[zookeeper-3.3.3.jar:3.3.3-1073969]
> 	at org.apache.zookeeper.KeeperException.create(KeeperException.java:42) ~[zookeeper-3.3.3.jar:3.3.3-1073969]
> 	at org.apache.zookeeper.ZooKeeper.create(ZooKeeper.java:637) ~[zookeeper-3.3.3.jar:3.3.3-1073969]
> 	at org.I0Itec.zkclient.ZkConnection.create(ZkConnection.java:87) ~[zkclient-0.1.jar:na]
> 	at org.I0Itec.zkclient.ZkClient$1.call(ZkClient.java:308) ~[zkclient-0.1.jar:na]
> 	at org.I0Itec.zkclient.ZkClient$1.call(ZkClient.java:304) ~[zkclient-0.1.jar:na]
> 	at org.I0Itec.zkclient.ZkClient.retryUntilConnected(ZkClient.java:675) ~[zkclient-0.1.jar:na]
> 	... 8 common frames omitted
> Anyone can help me ?
> Thanks
> Bohr


There was a typo in the text: you want to deploy to "cluster1", not "c1".

I modified the wiki accordingly.

Thanks for reporting that!

(And again, that's also a path where we need to add more meaningful 
error messages).

Matthieu

Mime
View raw message