incubator-s4-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From raghavendhra rahul <raghavendhrara...@gmail.com>
Subject Re: Redirecting Stream
Date Fri, 20 Jan 2012 11:44:23 GMT
While running in single node i get the following log in the adapter
2012-01-20 15:42:21,717 monitor INFO (Log4jMonitor.java:57)
S4::S4CoreMetrics:gl_in = 2
2012-01-20 15:42:21,718 monitor INFO (Log4jMonitor.java:57)
S4::S4CoreMetrics:lle_out = 1000
2012-01-20 15:42:21,718 monitor INFO (Log4jMonitor.java:57)
S4::S4CoreMetrics:lle_qsz = 0
2012-01-20 15:42:21,719 monitor INFO (Log4jMonitor.java:57)
S4::S4CoreMetrics:lll_in = 2
2012-01-20 15:42:21,719 monitor INFO (Log4jMonitor.java:57)
S4::S4EventMetrics:gl_in:et:OutPut = 2
2012-01-20 15:42:21,719 monitor INFO (Log4jMonitor.java:57)
S4::S4CoreMetrics:lll_qsz = 1

But in multi node

2012-01-20 15:42:21,717 monitor INFO (Log4jMonitor.java:57)
S4::S4CoreMetrics:gl_in = 2
2012-01-20 15:42:21,718 monitor INFO (Log4jMonitor.java:57)
S4::S4CoreMetrics:lle_out = 1000

I cannot get the output stream from the external driver.Am i missing
somrthing in configuration

On Fri, Jan 20, 2012 at 3:22 PM, raghavendhra rahul <
raghavendhrarahul@gmail.com> wrote:

> Actually d.recv() is getting output when s4 cluster is formed within the
> single node.But with multinode environment d.recv() is not returning any
> value
>
>
> On Fri, Jan 20, 2012 at 2:47 PM, Matthieu Morel <mmorel@apache.org> wrote:
>
>> Hi,
>>
>> we don't know your application or your environment so there isn't much we
>> can say at this point. You should investigate the issue more deeply by
>> adding logs and starting from simple applications.
>>
>> Matthieu
>>
>>
>> On 1/20/12 9:33 AM, raghavendhra rahul wrote:
>>
>>> Any suggestions....
>>>
>>> On Fri, Jan 20, 2012 at 11:12 AM, raghavendhra rahul
>>> <raghavendhrarahul@gmail.com <mailto:raghavendhrarahul@**gmail.com<raghavendhrarahul@gmail.com>>>
>>> wrote:
>>>
>>>    Hi,
>>>         I used io.s4.dispatcher.**StreamSelectingDispatcher and
>>>    redirected one stream to the client adapter and using an external
>>>    application i read from the stream.During single node configuration
>>>    i get the results out of the stream.But while running in cluster
>>>    mode i cannot get the result out of the stream.
>>>     From the logs i can see that a new client is connected to the
>>>    adapter when i run the external application.But i cannot get any
>>>    values from the output stream.
>>>
>>>    Any Suggestions....
>>>    Am i missing something....
>>>
>>>
>>>
>>
>

Mime
View raw message