incubator-s4-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jaime D (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (S4-111) Deployment fails getting the .s4r file from the web
Date Fri, 14 Dec 2012 20:40:12 GMT

     [ https://issues.apache.org/jira/browse/S4-111?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jaime D updated S4-111:
-----------------------

    Description: 
Using 0.5.0. Trying to deploy an example s4 app in a distributed environment. First I build
the s4r file, leave it in a web server accessible from my machines, and execute the following,
getting an error:


{code:none}
./s4 deploy -s4r=http://<server>/<path>/twitter-adapter.s4r
  -c=cluster2 -appName=twitter-adapter

01:15:52.584 [main] ERROR org.apache.s4.tools.Deploy
  Specified S4R file does not exist in
  /home/jaime/s4/http:/<server>/<path>/twitter-adapter.s4r
{code}

Note from Matthieu: Fetching from http works when the s4r file URI is correct in ZooKeeper.
Unfortunately that does not seem to work directly when using the Deploy tool

  was:
Using 0.5.0. Trying to deploy an example s4 app in a distributed environment. First I build
the s4r file, leave it in a web server accessible from my machines, and execute the following,
getting an error:

{code:none}
./s4 deploy -s4r=http://<server>/<path>/twitter-adapter.s4r
  -c=cluster2 -appName=twitter-adapter

01:15:52.584 [main] ERROR org.apache.s4.tools.Deploy
  Specified S4R file does not exist in
  /home/jaime/s4/http:/<server>/<path>/twitter-adapter.s4r
{code}

Note from Matthieu: Fetching from http works when the s4r file URI is correct in ZooKeeper.
Unfortunately that does not seem to work directly when using the Deploy tool

    
> Deployment fails getting the .s4r file from the web
> ---------------------------------------------------
>
>                 Key: S4-111
>                 URL: https://issues.apache.org/jira/browse/S4-111
>             Project: Apache S4
>          Issue Type: Bug
>    Affects Versions: 0.5.0
>            Reporter: Jaime D
>            Priority: Minor
>              Labels: deployment, distributed
>             Fix For: 0.6
>
>
> Using 0.5.0. Trying to deploy an example s4 app in a distributed environment. First I
build the s4r file, leave it in a web server accessible from my machines, and execute the
following, getting an error:
> {code:none}
> ./s4 deploy -s4r=http://<server>/<path>/twitter-adapter.s4r
>   -c=cluster2 -appName=twitter-adapter
> 01:15:52.584 [main] ERROR org.apache.s4.tools.Deploy
>   Specified S4R file does not exist in
>   /home/jaime/s4/http:/<server>/<path>/twitter-adapter.s4r
> {code}
> Note from Matthieu: Fetching from http works when the s4r file URI is correct in ZooKeeper.
Unfortunately that does not seem to work directly when using the Deploy tool

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message