incubator-s4-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthieu Morel (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (S4-80) Shade platform dependencies
Date Fri, 20 Jul 2012 13:48:36 GMT

     [ https://issues.apache.org/jira/browse/S4-80?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Matthieu Morel updated S4-80:
-----------------------------

    Fix Version/s: 0.6

Postponing this task for the next release. For 0.5, I will update the Guava lib to make sure
we use the latest one in order to minimize potential issues in user code. Along with explicit
documentation.
                
> Shade platform dependencies
> ---------------------------
>
>                 Key: S4-80
>                 URL: https://issues.apache.org/jira/browse/S4-80
>             Project: Apache S4
>          Issue Type: Task
>    Affects Versions: 0.5
>            Reporter: Matthieu Morel
>             Fix For: 0.6
>
>
> Some of the dependencies should be shaded so that there is no conflict with user dependencies.
In particular, utility libraries such as guava or apache commons.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message