incubator-s4-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Leo Neumeyer <leoneume...@gmail.com>
Subject Re: piper build error with Gradle 1.0-milestone-7
Date Sat, 04 Feb 2012 19:36:02 GMT
Reverted the piper branch in the repo. I confirmed that it works with
gradle 1.0 M5 and breaks in M7 so don't upgrade until we find a fix.

-leo

On Sat, Feb 4, 2012 at 11:03 AM, Leo Neumeyer <leoneumeyer@gmail.com> wrote:
> Setting transient = falseĀ  didn't work. It looks like ZK uses log4j
> and log4j requires jms. jms is not longer available in the repo
> because of licensing iissues. The jms jar is not needed and should be
> excluded but don't know how how to exclude a jar dependency in Gradle.
> Does anyone have a suggestion? The piper branch is broken now.
>
> -leo
>
> On Thu, Feb 2, 2012 at 6:29 PM, Leo Neumeyer <leoneumeyer@gmail.com> wrote:
>> I think I tracked the problem to a bad maven repository. The build
>> script couldn't find the jms artifact which is a dependency from zk
>> and zkclient. I set transient to false in the main build script and in
>> s4-comm. This seems to solve the problem for now but we need a better
>> solution. I merged the changes back to the piper branch.
>>
>> -leo
>>
>> On Thu, Feb 2, 2012 at 4:31 PM, Leo Neumeyer <leoneumeyer@gmail.com> wrote:
>>> can someone else try to build with Gradle 1.0-milestone-7 to confirm
>>> that it is broken?
>>>
>>> --
>>>
>>> Leo Neumeyer (@leoneu)
>>
>>
>>
>> --
>>
>> Leo Neumeyer (@leoneu)
>
>
>
> --
>
> Leo Neumeyer (@leoneu)



-- 

Leo Neumeyer (@leoneu)

Mime
View raw message