incubator-s4-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karthik Kambatla (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (S4-18) gradle test fails
Date Fri, 28 Oct 2011 01:25:32 GMT

    [ https://issues.apache.org/jira/browse/S4-18?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13137813#comment-13137813
] 

Karthik Kambatla commented on S4-18:
------------------------------------

I also tried running gradle test from within subprojects/s4-comm. Interestingly, it fails
reporting the same error, but only after running all the tests. I doubt if it has to do with
permissions to write the report.


kkambatl@keka:~/code/s4-piper/subprojects/s4-comm$ gradle clean test
:s4-comm:clean
:s4-base:compileJava UP-TO-DATE
:s4-base:processResources UP-TO-DATE
:s4-base:classes UP-TO-DATE
:s4-base:jar
:s4-comm:compileJava
:s4-comm:processResources
:s4-comm:classes
:s4-comm:compileTestJava
:s4-comm:processTestResources
:s4-comm:testClasses
:s4-comm:test

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':s4-comm:test'.
Cause: Could not generate test report to '/home/kkambatl/code/s4-piper/subprojects/s4-comm/build/reports/tests'.
Cause: java.lang.NullPointerException (no error message)

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to
get more log output.

BUILD FAILED

                
> gradle test fails
> -----------------
>
>                 Key: S4-18
>                 URL: https://issues.apache.org/jira/browse/S4-18
>             Project: Apache S4
>          Issue Type: Bug
>    Affects Versions: 0.5
>         Environment: Ubuntu 11.10; gradle version - 1.0-milestone-3, installed via 'apt-get
install gradle'
>            Reporter: Karthik Kambatla
>              Labels: gradle, test
>             Fix For: 0.5
>
>         Attachments: gradle-test-stacktrace-info.txt
>
>
> gradle test fails with a NullPointerException while executing the non-existent tests
under s4-base

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message