incubator-river-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wade Chandler <hwadechandler-apa...@yahoo.com>
Subject Re: Java Version for Jini Platform Service Servers
Date Thu, 30 Dec 2010 19:26:26 GMT
----- Original Message ----

> From: Sim IJskes - QCG <sim@qcg.nl>
> To: river-dev@incubator.apache.org
> Sent: Thu, December 30, 2010 6:10:51 AM
> Subject: Re: Java Version for Jini Platform Service Servers
> 
> On 29-12-10 23:16, Peter Firmstone wrote:
> > Java Minimum Version for Jini  Platform Service Server side implementations:
> >
> > Java 6:
> > +1  Peter Firmstone
> 
> Peter, do you have a proposal how to verify the  compatibility of the 
> proxy classes?
> 

These being the ones where they are being loaded dynamically? These are the 
types of cases I was thinking animal-sniffer wouldn't be able to help. These are 
where I think the rubber hits the road and the only real way is to run them in 
their correct deployment version and see if they pass. i.e. unit tests can load 
them and run them correctly... I don't really know any other way around that 
unless you wrote some kind of a tree visitor for the sources which could 
determine that reflection was being used to lookup and load a class, and even 
then, you'd have to have that logic be able to find the exact values being 
passed in. Leads me to think the only *real* way to do it is unit tests in the 
target platforms.

Wade

 ==================
Wade Chandler
Software Engineer and Developer
NetBeans Dream Team Member and Contributor

http://wiki.netbeans.org/wiki/view/NetBeansDreamTeam
http://www.netbeans.org

Mime
View raw message