incubator-photark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anuj Kumar <anujs...@gmail.com>
Subject Build Failure
Date Sat, 28 Jan 2012 04:54:48 GMT
Hello Everyone,

I am trying to build the trunk and the build is failing with this error-

[INFO] Unable to find resource
'com.jayway.maven.plugins.android.generation2:maven-android-plugin:pom:3.0.2'
in repository apache.incubator (
http://people.apache.org/repo/m2-incubating-repository)
Downloading:
http://repo1.maven.org/maven2/com/jayway/maven/plugins/android/generation2/maven-android-plugin/3.0.2/maven-android-plugin-3.0.2.pom
[INFO] Unable to find resource
'com.jayway.maven.plugins.android.generation2:maven-android-plugin:pom:3.0.2'
in repository central (http://repo1.maven.org/maven2)
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Error building POM (may not be this project's POM).


Project ID:
com.jayway.maven.plugins.android.generation2:maven-android-plugin

Reason: POM
'com.jayway.maven.plugins.android.generation2:maven-android-plugin' not
found in repository: Unable to download the artifact from any repository


com.jayway.maven.plugins.android.generation2:maven-android-plugin:pom:3.0.2

from the specified remote repositories:
  apache.snapshots (http://people.apache.org/repo/m2-snapshot-repository),
  central (http://repo1.maven.org/maven2),
  apache.incubator (http://people.apache.org/repo/m2-incubating-repository)

 for project
com.jayway.maven.plugins.android.generation2:maven-android-plugin


[INFO]
------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 2 seconds
[INFO] Finished at: Sat Jan 28 10:05:01 IST 2012
[INFO] Final Memory: 3M/70M
[INFO]
------------------------------------------------------------------------

The issue is with the Android module. If I disable it, build succeeds as
expected-

[INFO]
[INFO]
[INFO]
------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO]
------------------------------------------------------------------------
[INFO] Apache PhotArk ........................................ SUCCESS
[3.604s]
[INFO] Apache PhotArk Common Services ........................ SUCCESS
[6.909s]
[INFO] Apache PhotArk Security Services ...................... SUCCESS
[4.411s]
[INFO] Apache PhotArk FileSystem Services .................... SUCCESS
[6.331s]
[INFO] Apache PhotArk Flickr Photo Album Subscription ........ SUCCESS
[7.709s]
[INFO] Apache PhotArk Google Picasa Photo Album Subscription . SUCCESS
[32.620s]
[INFO] Apache PhotArk JCR based Implementation ............... SUCCESS
[13.423s]
[INFO] Apache PhotArk Search Services ........................ SUCCESS
[3.650s]
[INFO] Apache PhotArk Common UI .............................. SUCCESS
[2.212s]
[INFO] Apache PhotArk Common Admin UI ........................ SUCCESS
[2.814s]
[INFO] Apache PhotArk Security UI ............................ SUCCESS
[1.067s]
[INFO] Apache PhotArk Appengine Web Application .............. SUCCESS
[28.163s]
[INFO] Apache PhotArk Face Recognition Implementation ........ SUCCESS
[3.875s]
[INFO] Apache PhotArk Web Application ........................ SUCCESS
[20.012s]
[INFO]
------------------------------------------------------------------------
[INFO]
------------------------------------------------------------------------
[INFO] BUILD SUCCESSFUL
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 2 minutes 18 seconds
[INFO] Finished at: Sat Jan 28 10:23:44 IST 2012
[INFO] Final Memory: 120M/378M
[INFO]
------------------------------------------------------------------------

Any pointers to resolve the android module dependencies?

Regards,
Anuj

Mime
View raw message