incubator-oozie-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Prashant Kommireddi <prash1...@gmail.com>
Subject Re: Installation error
Date Sat, 21 Apr 2012 10:00:39 GMT
That did not work. I restarted Oozie after setting the following in
oozie-site.xml

  <property>
    <name>oozie.services.ext</name>
    <value>org.apache.oozie.service.HadoopAccessorService</value>
     <description>
         To use a Hadoop 20 distribution pre-security (i.e. 0.20.1) this
property must be set
    </description>
    </property>



On Sat, Apr 21, 2012 at 2:46 AM, Harsh J <harsh@cloudera.com> wrote:

> Prashant,
>
> As noted in the docs at
>
> http://incubator.apache.org/oozie/docs/3.1.3/docs/AG_Install.html#Oozie_Authentication_Configuration
>
> To use a Hadoop 20 distribution pre-security (i.e. 0.20.1) the
> following property must be set:
>
>  oozie.services.ext=org.apache.oozie.service.HadoopAccessorService
>
> (In oozie-site.xml)
>
> On Sat, Apr 21, 2012 at 3:12 PM, Prashant Kommireddi
> <prash1784@gmail.com> wrote:
> > Hi Harsh,
> >
> > Hadoop 0.20.2
> > Oozie 3.1.3
> >
> > On Sat, Apr 21, 2012 at 2:39 AM, Harsh J <harsh@cloudera.com> wrote:
> >
> >> Prashant,
> >>
> >> What version of Hadoop are you running against?
> >>
> >> On Sat, Apr 21, 2012 at 3:01 PM, Prashant Kommireddi
> >> <prash1784@gmail.com> wrote:
> >> > Hi All,
> >> >
> >> > I am trying to install Oozie (followed
> >> > http://incubator.apache.org/oozie/QuickStart.html#AG_Install) but
> seem
> >> to
> >> > be running into some issues. I see that Oozie server starts but the
> web
> >> > console reports 404 error. Would anyone have an idea what's going
> wrong
> >> > here?
> >> >
> >> > bin/oozie admin -oozie http://localhost:11000/oozie -status
> >> > Error: HTTP error code: 404 : Not Found
> >> >
> >> > I see a SEVERE message in localhost logs - could this be causing the
> >> issue?
> >> >
> >> > $ cat localhost.2012-04-21.log
> >> > Apr 21, 2012 2:25:51 AM org.apache.catalina.core.StandardContext
> >> > listenerStart
> >> > SEVERE: Exception sending context initialized event to listener
> instance
> >> of
> >> > class org.apache.oozie.servlet.ServicesLoader
> >> > java.lang.NoSuchMethodError:
> >> >
> >>
> org.apache.hadoop.security.UserGroupInformation.setConfiguration(Lorg/apache/hadoop/conf/Configuration;)V
> >> >    at
> >> >
> >>
> org.apache.oozie.service.KerberosHadoopAccessorService.init(KerberosHadoopAccessorService.java:95)
> >> >    at
> >> >
> >>
> org.apache.oozie.service.HadoopAccessorService.init(HadoopAccessorService.java:75)
> >> >    at
> >> >
> org.apache.oozie.service.Services.setServiceInternal(Services.java:310)
> >> >    at org.apache.oozie.service.Services.setService(Services.java:296)
> >> >    at org.apache.oozie.service.Services.init(Services.java:206)
> >> >    at
> >> >
> >>
> org.apache.oozie.servlet.ServicesLoader.contextInitialized(ServicesLoader.java:40)
> >> >    at
> >> >
> >>
> org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4205)
> >> >    at
> >> >
> org.apache.catalina.core.StandardContext.start(StandardContext.java:4704)
> >> >    at
> >> >
> >>
> org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:799)
> >> >    at
> >> >
> org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:779)
> >> >    at
> >> org.apache.catalina.core.StandardHost.addChild(StandardHost.java:601)
> >> >    at
> >> >
> >>
> org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:675)
> >> >    at
> >> >
> >>
> org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:601)
> >> >    at
> >> > org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:502)
> >> >    at
> org.apache.catalina.startup.HostConfig.start(HostConfig.java:1315)
> >> >    at
> >> >
> >>
> org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:324)
> >> >    at
> >> >
> >>
> org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:142)
> >> >    at
> >> org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1061)
> >> >    at
> org.apache.catalina.core.StandardHost.start(StandardHost.java:840)
> >> >    at
> >> org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1053)
> >> >    at
> >> > org.apache.catalina.core.StandardEngine.start(StandardEngine.java:463)
> >> >    at
> >> >
> org.apache.catalina.core.StandardService.start(StandardService.java:525)
> >> >    at
> >> > org.apache.catalina.core.StandardServer.start(StandardServer.java:754)
> >> >    at org.apache.catalina.startup.Catalina.start(Catalina.java:595)
> >> >    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> >> >    at
> >> >
> >>
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
> >> >    at
> >> >
> >>
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
> >> >    at java.lang.reflect.Method.invoke(Method.java:597)
> >> >    at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)
> >> >    at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)
> >> > pkommireddi@pkommireddi-wsl
> >> :~/hadoopeco/oozie/oozie-3.1.3-incubating/logs$
> >> >
> >> >
> >> > Here is *oozie.log*
> >> > $ cat oozie.log
> >> > 2012-04-21 02:25:51,461  INFO XLogService:539 -
> >> >
> >>
>  *******************************************************************************
> >> >
> >> >  STARTUP MSG: Oozie BUILD_VERSION [3.1.3-incubating] compiled by
> [kamrul]
> >> > on [2012.02.29-18:52:47GMT]
> >> >  STARTUP MSG:       revision [unavailable]@[unavailable]
> >> >
> >>
> *******************************************************************************
> >> > 2012-04-21 02:25:51,464  INFO XLogService:539 - Log4j configuration
> file
> >> > [oozie-log4j.properties]
> >> > 2012-04-21 02:25:51,464  INFO XLogService:539 - Log4j configuration
> file
> >> > loaded from
> >> [/home/pkommireddi/hadoopeco/oozie/oozie-3.1.3-incubating/conf]
> >> > 2012-04-21 02:25:51,465  INFO XLogService:539 - Log4j reload interval
> [10
> >> > sec]
> >> > 2012-04-21 02:25:51,475  INFO ConfigurationService:539 - USER[-]
> GROUP[-]
> >> > Oozie home dir
> >>  [/home/pkommireddi/hadoopeco/oozie/oozie-3.1.3-incubating]
> >> > 2012-04-21 02:25:51,475  INFO ConfigurationService:539 - USER[-]
> GROUP[-]
> >> > Oozie conf dir
> >> > [/home/pkommireddi/hadoopeco/oozie/oozie-3.1.3-incubating/conf]
> >> > 2012-04-21 02:25:51,476  INFO ConfigurationService:539 - USER[-]
> GROUP[-]
> >> > Oozie conf file [oozie-site.xml]
> >> > 2012-04-21 02:25:51,496  INFO ConfigurationService:539 - USER[-]
> GROUP[-]
> >> > Configuration change via System Property, [oozie.base.url]=[
> >> > http://pkommireddi-wsl.internal.salesforce.com:11000/oozie]
> >> > 2012-04-21 02:25:51,497  WARN Services:542 - USER[-] GROUP[-] System
> ID
> >> > [oozie-pkom] exceeds maximum length [10], trimming
> >> > 2012-04-21 02:25:51,498  INFO Services:539 - USER[-] GROUP[-] Exiting
> >> null
> >> > Entering NORMAL
> >> > 2012-04-21 02:25:51,499  INFO Services:539 - USER[-] GROUP[-]
> Initialized
> >> > runtime directory
> >> >
> >>
> [/home/pkommireddi/hadoopeco/oozie/oozie-3.1.3-incubating/oozie-server/temp/oozie-pkom336508450508963108.dir]
> >> > 2012-04-21 02:25:51,562  WARN AuthorizationService:542 - USER[-]
> GROUP[-]
> >> > Oozie running with security disabled
> >> > 2012-04-21 02:25:51,563  INFO KerberosHadoopAccessorService:539 -
> USER[-]
> >> > GROUP[-] JOB_TRACKER_WHITELIST :[ ], Total entries :0
> >> > 2012-04-21 02:25:51,563  INFO KerberosHadoopAccessorService:539 -
> USER[-]
> >> > GROUP[-] NAME_NODE_WHITELIST :[ ], Total entries :0
> >> > 2012-04-21 02:25:51,564  INFO KerberosHadoopAccessorService:539 -
> USER[-]
> >> > GROUP[-] Oozie Kerberos Authentication [disabled]
> >> > 2012-04-21 02:25:51,637  INFO Services:539 - Shutdown
> >> >
> >> > Thanks,
> >> > Prashant
> >>
> >>
> >>
> >> --
> >> Harsh J
> >>
>
>
>
> --
> Harsh J
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message