incubator-oozie-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simone Tripodi <simonetrip...@apache.org>
Subject Re: failing startup in tomcat
Date Thu, 13 Oct 2011 09:44:31 GMT
Thanks for the prompt reply Mohammad, very appreciated!!!
Going to give a try right now, I'll let you know!
All the best,
Simo

http://people.apache.org/~simonetripodi/
http://simonetripodi.livejournal.com/
http://twitter.com/simonetripodi
http://www.99soft.org/



On Thu, Oct 13, 2011 at 11:42 AM, Mohammad Islam <mislam77@yahoo.com> wrote:
> Hi Simone,
> As suspected, it is a known Oozie issue when running with hadoop non-secured version.
If you are using non-secured hadoop , please use this solution provided here
> https://github.com/yahoo/oozie/wiki/FAQ
>
>
> Anyway, oozie needs to take care of this issue. I think there is already a JIRA for this.
>
>
> Please let us know how it goes.
>
> Regards,
> Mohammad
>
>
>
> ________________________________
> From: Simone Tripodi <simonetripodi@apache.org>
> To: oozie-users@incubator.apache.org
> Sent: Thursday, October 13, 2011 2:22 AM
> Subject: Re: failing startup in tomcat
>
> Hi Angelo and Mohammad,
> thanks for you help on driving me on the right direction!
>
> Yes, forgot to mention that I configured the oozie-site.xml in the
> following way: https://gist.github.com/1283797
>
> And MySQL driver included (as in the previous email) via CLI:
> https://gist.github.com/1283799
>
> When launching oozie with `$ ./bin/oozie-run.sh` I get the following errors:
> * shell: https://gist.github.com/1283808
> * log files: https://gist.github.com/1283826
>
> I really want to say a big thank you in advance!
> All the best, have a nice day!
> Simo
>
> http://people.apache.org/~simonetripodi/
> http://simonetripodi.livejournal.com/
> http://twitter.com/simonetripodi
> http://www.99soft.org/
>
>
>
> On Thu, Oct 13, 2011 at 3:28 AM, Mohammad Islam <mislam77@yahoo.com> wrote:
>> In addition, would you please send any error message shown in the oozie.log, catalina.out
and localhost-*. Some other specific error could be helpful.
>>
>> Regards,
>> Mohammad
>>
>>
>>
>> ________________________________
>> From: Angelo K. Huang <angelohuang@gmail.com>
>> To: oozie-users@incubator.apache.org
>> Sent: Wednesday, October 12, 2011 6:12 PM
>> Subject: Re: failing startup in tomcat
>>
>> Without setting mysql, are you able to start Oozie? Did you add jdbc driver
>> value to oozie-site.xml? You can find the jdbc configuration from
>> oozie-default.xml and copy to oozie-site.xml with new value for mysql.
>>
>> Thanks,
>> Angelo
>>
>> On Wed, Oct 12, 2011 at 3:13 AM, Simone Tripodi <simonetripodi@apache.org>wrote:
>>
>>> Hi all guys,
>>> I'm totally new to Oozie and browsed google/markmail/yahoo group to
>>> resolve my issue, but didn't achieve it ;(
>>>
>>> This is my scenario:
>>>  * oozie-3.0.2
>>>  * ext-2.2
>>>  * hadoop-0.20.2
>>>  * mysql-connector-java-5.1.18
>>>
>>> Modified the ${OOZIE_HOME}/conf/oozie-site.xml to put the correct JDBC
>>> parameters to get a connection;
>>>
>>> Packaged Oozie running
>>>
>>>    oozie-3.0.2 simonetripodi$ ./bin/oozie-setup.sh -hadoop 0.20.2
>>> /Applications/hadoop-0.20.2 -extjs /Applications/ext-2.2 -jars
>>>
>>> /Users/simonetripodi/Downloads/mysql-connector-java-5.1.18/mysql-connector-java-5.1.18-bin.jar
>>>
>>> and finally launched Oozie:
>>>
>>>    oozie-3.0.2 simonetripodi$ ./bin/oozie-run.sh
>>>
>>> unfortunately I got the following
>>>
>>> SEVERE: Error listenerStart
>>> Oct 12, 2011 11:23:43 AM org.apache.catalina.core.StandardContext start
>>> SEVERE: Context [/oozie] startup failed due to previous errors
>>> Oct 12, 2011 11:23:44 AM org.apache.catalina.loader.WebappClassLoader
>>> clearReferencesJdbc
>>> SEVERE: The web application [/oozie] registered the JDBC driver
>>> [org.apache.derby.jdbc.AutoloadedDriver] but failed to unregister it
>>> when the web application was stopped. To prevent a memory leak, the
>>> JDBC Driver has been forcibly unregistered.
>>> Oct 12, 2011 11:23:44 AM org.apache.catalina.loader.WebappClassLoader
>>> clearReferencesJdbc
>>> SEVERE: The web application [/oozie] registered the JDBC driver
>>> [com.mysql.jdbc.Driver] but failed to unregister it when the web
>>> application was stopped. To prevent a memory leak, the JDBC Driver has
>>> been forcibly unregistered.
>>> Oct 12, 2011 11:23:44 AM org.apache.catalina.loader.WebappClassLoader
>>> clearReferencesThreads
>>> SEVERE: The web application [/oozie] appears to have started a thread
>>> named [Thread-3] but has failed to stop it. This is very likely to
>>> create a memory leak.
>>> Oct 12, 2011 11:23:44 AM org.apache.catalina.loader.WebappClassLoader
>>> clearThreadLocalMap
>>> SEVERE: The web application [/oozie] created a ThreadLocal with key of
>>> type [org.apache.oozie.util.XLog$Info$1] (value
>>> [org.apache.oozie.util.XLog$Info$1@4b8a6e6e]) and a value of type
>>> [org.apache.oozie.util.XLog.Info] (value
>>> [org.apache.oozie.util.XLog$Info@6d581e80]) but failed to remove it
>>> when the web application was stopped. This is very likely to create a
>>> memory leak.
>>>
>>> I've been reading this thread[1] but didn't understand how to arrange
>>> things inside Oozie to make it work.
>>> Please help me, I have been trying for the whole morning without success ;(
>>> TIA, all the best,
>>> Simo
>>>
>>> [1] http://s.apache.org/7ii
>>>
>>> http://people.apache.org/~simonetripodi/
>>> http://simonetripodi.livejournal.com/
>>> http://twitter.com/simonetripodi
>>> http://www.99soft.org/
>>>

Mime
View raw message