incubator-ooo-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ennio Sr <nasr.la...@gmail.com>
Subject Re: Macros: from OO_2.0 to OO_3.4
Date Thu, 30 Aug 2012 17:20:13 GMT
On Wed, Aug 29, 2012 at 6:57 PM, Ariel Constenla-Haile
<arielch@apache.org> wrote:
> Hi Ennio,
>
> On Wed, Aug 29, 2012 at 06:47:10PM +0200, Ennio-Sr wrote:
>> How can I make OO_2 macros work under OO_3.4?
>>
>> It seems that keys association (which should be set by the ALT+0 macro)
>> are not recorded. AAMOF the ALT+0 ran automagically in OO_2 when the file
>> was opened and loaded a KeyBrdCfg macro (setting key association).[*]
>> If I try to run this wia Tools/Macros/Organize Macros/OpenOffice
>> Basic/Run a warning appears saying:
>>       BASIC runtime error
>>       An exception occurred
>>       Type: com.sun.star.io.IOException
>>       Message: .
>> and the relative script stops on the line:
>> shortCuts.store()
>
> In this macro, what is shortCuts? Can you post the Basic code or point
> to a document with the macro included?
>
>
> Regards
> --
> Ariel Constenla-Haile
> La Plata, Argentina

Hi Ariel,

I uploaded an .odt copy of my macros to:
http://tinyurl.com/yee4a86
The password, if required, is 'guest', and the file name
'Load_KbdCfg-copy.txt.odt'
Almost at the top is the '_0_show_menu' macro which runs when I open
one of the Calc-files where the 'Open Document' event
(Tools/Customize/Events) has been associated with a:
'cc_Library_Macros_for_all_cc_0_show_menu'. The macro stops at the
'shortCuts()' line and, of course, none of the Alt+key association
works.
If I use the Tools/Customize/Keyboard the make manually these
association they work, axcept the Alt+M, which will miniaturize the
screen instead of positionin the cursor on the Menu.

In the same dir where my Calc-files are, there are also a
'AAA_KbdCfg_CC-uno.pkg' (which I am unable to recall what it was for)
and a 'AAA-KbdCfgCC_LibMacros' (this being the file I talked about in
my previous post, where I had saved my macros when working with OO_2).
BTW, the version I'm currently using is the 3.2.1.4, Debian.

Thanks for your help. Regards, Ennio

-- 
[Perche' usare Win$ozz (dico io) se ..."anche uno sciocco sa farlo.   \\?//
 Fa' qualche cosa di cui non sei capace!"  (diceva Henry Miller) ]    (°|°)
[Why use Win$ozz (I say) if ... "even a fool can do that.              )=(
 Do something you aren't good at!" (as Henry Miller used to say) ]

---------------------------------------------------------------------
To unsubscribe, e-mail: ooo-users-unsubscribe@incubator.apache.org
For additional commands, e-mail: ooo-users-help@incubator.apache.org


Mime
View raw message