incubator-ooo-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rich Midwinter <rich.midwin...@gmail.com>
Subject Re: Default ocale in headless mode
Date Mon, 23 Jul 2012 13:49:59 GMT
I've tried running soffice and (after going through the first start wizard)
seeing what's entered in the language settings, but that seemed to default
to en_GB equivalent values.

Thanks

On 23 July 2012 14:34, Regina Henschel <rb.henschel@t-online.de> wrote:

> Hi Richard,
>
> Richard Midwinter schrieb:
>
>  Hi
>>
>> I'm running OOo in headless mode on a Linux instance, using a command much
>> like:
>>
>> $ soffice.bin
>> -accept=socket,host=127.0.0.1,**port=8100;urp;StarOffice.**ServiceManager
>> -env:UserInstallation=file:///**var/data/alfresco/oouser -nologo
>> -headless
>> -nofirststartwizard -nocrashrep -norestore
>>
>> It's generating document previews for us. Unfortunately the previews
>> generated appear to be in an en_US locale, such as for Excel documents
>> uploaded with a date in. Explicitly setting the locale for a cell in Excel
>> is respected by OOo, this is only for the default case. We'd like to use
>> en_GB and the output of $ echo $LANG is en_GB.UTF-8.
>>
>> How could I set the default locale for OOo?
>>
>
> Have you already tried to call AOO for this special user with UI, and then
> set the local and the other language settings to en-GB? When you have
> started AOO, you will find it in Tools > Options > Language Settings >
> Languages.
>
> Kind regards
> Regina
>
>
> ------------------------------**------------------------------**---------
> To unsubscribe, e-mail: ooo-users-unsubscribe@**incubator.apache.org<ooo-users-unsubscribe@incubator.apache.org>
> For additional commands, e-mail: ooo-users-help@incubator.**apache.org<ooo-users-help@incubator.apache.org>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message