incubator-ooo-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Aitken ...@dreamchaser.org>
Subject Re: Dates changed on entry in database [mostly solved]
Date Sat, 30 Jun 2012 04:52:35 GMT
On 06/29/12 02:08, Alex Thurgood wrote:

>> I have a form connected to a mysql database with a datetime field.
>> The first time I enter a date for a new record, with the time portion of the field
still empty, the day is changed to be one day less.  For example, if I enter 2012-06-27 the
date is reformatted and changed to 06/26/12.  If I then clear out the date and time, and enter
the time, the date is set to 01/01/1800.
> 
> The offset is an old, old bug that has haunted OOo for years and raises its ugly head
on a regular basis, then gets forgotten about (or the bug report dismissed), as it doesn't
always seem to be reproducible. In the past, I've opened at least one I can definitely remember,
but possibly 2 or 3 bug reports for this terrible behaviour, but each time they were closed
as unreproducible. There was also a discussion somewhere on the dba OOo mailing lists at one
stage, but I guess that could only be found now by trawling the archives of those lists.

This behavior is totally reproduceable, although I might have to ship someone the db and the
form.

>> Or if that's not possible, how do I change the date display for a datetime field
in a base form?  I tried ungrouping the label + datetime field, then ungrouping the datetime
field, then doing Format but everything is greyed out.
> 
> If you are in Form design mode, then you should be able to access the form's controls
properties by right mouse button clicking on a field control representing the bound data field,
and then setting its "properties" from the context menu. If you can't do this, then either
your form is not properly bound to the underlying data, or else it is a bug.

Ah, thanks, I had looked for it there before but did not ungroup the combined datetime field
to find it.

It turns out setting the format to something other than "Standard (Short)" also gets rid of
the date-change problem.  So that gets around the problem for me, but doesn't fix the outstanding
bug and the lack of a way to set the default date format.

I will add a comment to the old bug and if it's not reopened in a bit I'll try to remember
to file a new one.  Thanks!

Gary



  

---------------------------------------------------------------------
To unsubscribe, e-mail: ooo-users-unsubscribe@incubator.apache.org
For additional commands, e-mail: ooo-users-help@incubator.apache.org


Mime
View raw message