incubator-ooo-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rod Lockwood" <rodlockw...@provide.net>
Subject Re: Installing Apache OpenOffice over LibreOffice
Date Tue, 15 May 2012 12:59:02 GMT
On Mon, 14 May 2012 21:16:29 -0400, NoOp <glgxg@sbcglobal.net> wrote:

> Whoa Stop!
>
> On 05/14/2012 06:43 AM, Rory O'Farrell wrote:
>> On Mon, 14 May 2012 13:25:37 +0000 (UTC) David H <zhotrum@live.com>
>> wrote:
>>
>>> Rod Lockwood <rodlockwood <at> provide.net> writes:
>>>
>>>>
>>>> Well, it worked. It still removed the old install of OpenOffice.
>>>> I had to rename the LibreOffice folder under Users/<user>/ to
>>>> OpenOffice.org, but after that everything went fine.
>>>>
>>>> However, the arrow keys don’t work. The touch pad moves the
>>>> cursor around and I can use the rest of the keys, but not the
>>>> arrow keys. The arrow keys on the numeric keypad won’t work
>>>> either.
>>>>
>>>> Whether this is because I installed into the LibreOffice folder I
>>>> don’t know.
>>>>
>>>
>>>
> ...
>>> dave@Daves-Home:~/en-US/DEBS/desktop-integration$ sudo dpkg -i
>>> *.deb (Reading database ... 184115 files and directories currently
>>> installed.) Unpacking openoffice.org-debian-menus (from
>>> openoffice.org3.4-debian-menus_3.4-9590_all. deb) ... dpkg: error
>>> processing openoffice.org3.4- debian-menus_3.4-9590_all.deb
>>> (--install): trying to overwrite '/usr/share/mime/packages/
>>> openoffice.org.xml', which is also in package libreoffice-common
>>> 1:3.4.4-0ubuntu1 dpkg-deb: error: subprocess paste was killed by
> ...
>
> The error is written for you.
>
>>> I have removed Libre through apt-get purge but a remnant is still
>>> there. I get a menu in Office- LibreOffice. I have tried but do not
>>> know how to get rid of this remnant. Is this messing with my
>>> install? How do I get rid of it?
>>>
>>
>> Try Sudo apt-get remove libreoffice-core
>>
>> Then delete your OpenOffice profile ad previous Libreoffice profiles.
>> Easiest way is to open your Home folder, enable viewing of Hidden
>> Files (Ctrl H in Nautilus) and then delete or rename .openoffice and
>> .libreoffice.  Now reboot (perhaps not strictly necessary, but I
>> always do it - remembering old Windows install problems).  Now
>> reinstall AOO 3.4.  Hopefully all should now be well.
>>
>
>
> It seems that the "advice" (even in the AOO developer threads) is to rip
> out/purge LO in order to install AOO. This is just plain wrong... LO
> "advise" says the same about OOo/AOO.
>
> Please... it's not necessary to remove *anything* with a linux install
> of AOO - unless of course you can't figure out how to create a menu
> launcher/link to /opt/openoffice.org3/program/soffice. AOO will exist
> happily alongside LibreOffice (any flavor), and even older versions of  
> OOo.
>
> @Rod: No idea what you were replying to, or to whom, but your *only*
> issue with the install it seems is attempting to install the
> desktop-integration .deb. Don't.

??? Excuse me? That is not my issue. MY issue has to do with the arrow  
keys not working. Re-read the piece of message that you clipped from my  
post.

And I am using Windows 7 Home Edition etc. I wrote that at the top of that  
post.

> The desktop-integration .deb (in OOo, AOO, LO) is, from a user
> perspective, an antiquated piece of code that should have been replaced
> long ago. Rather than providing independent /opt/ standard freedesktop
> menus, icons, and setup, openoffice.org3.4-debian-menus_3.4-9590_all.deb
> (and the others), the deb attempts to overwrite existing distro packaged
> code. This has been apparent for years in OOo - and so we (users) live
> with it and simply bypass any provided 'menus' deb file.
>
> All you need to do is install the main /AOOen-US3.4/DEBS files, and then
> create a menu/launcher to /opt/openoffice.org3/program/soffice - done.
> Unless of course you also have an old install of linux OOo/go-oo
> installed and do not wish to use/overwrite the user profile for that. In
> this case (Ubuntu/Debian)
>
> sudo gedit /opt/openoffice.org3/program/bootstraprc
>
> and then modify line 5 to:
> UserInstallation=$SYSUSERCONFIG/.openoffice.org3.4/3
> Done again.
>
> You'll then be able to run multiple versions of OO (AOO, OOo, LO) at the
> same time in parallel to each other. As an example, on this system I
> have the following:
>
> $ locate soffice.bin
> /opt/libreoffice/program/soffice.bin
> /opt/libreoffice3.4/program/soffice.bin
> /opt/libreoffice3.5/program/soffice.bin
> /opt/ooo-dev3/program/soffice.bin
> /opt/openoffice.org3/program/soffice.bin
> /usr/lib/libreoffice/program/soffice.bin
>
> I didn't have to "purge" anything to accomplish this.

I didn’t have to "purge" anything either. I think you are responding to  
the wrong message.

>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: ooo-users-unsubscribe@incubator.apache.org
> For additional commands, e-mail: ooo-users-help@incubator.apache.org
>


-- 
Later Sincerely,
Rod Lockwood
Rod’s Rants
Rod’s Belfry
Victorian Cosmos
My Facebook profile
webmaster, Pokémon Dungeon (White Phoenix)
founder, Gomorra Town Hall on Facebook
WhitePhoenix on IRC Chat
WhitePhoenixUS on YouTube and just about everywhere else
Support your local and online small businesses!
Feed the Pig.

---------------------------------------------------------------------
To unsubscribe, e-mail: ooo-users-unsubscribe@incubator.apache.org
For additional commands, e-mail: ooo-users-help@incubator.apache.org


Mime
View raw message