incubator-ooo-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Girvin R. Herr" <girvin.h...@sbcglobal.net>
Subject Re: Installing Apache OpenOffice over LibreOffice
Date Wed, 16 May 2012 01:22:04 GMT

There has been a lot of discussion in this forum with regards to installing AOO version 3.4.0
over Ooo version 3.3.0 and older and not being able to use the older version(s) after the
3.4 installation.  Most of that discussion is related to Windows problems and a few related
to *nix.  Here are my observations on this subject as it impacts my Linux computers.

I have just repackaged the 3.4.0 RPM binary distribution into a Slackware Linux package for
installation on my computers.  I looked at the directories that 3.4.0 uses and compared them
to the 3.3.0 directories and found several conflicts.  My investigation implies that 3.4.0
will, indeed, overwrite 3.3.0 and possibly older versions.  Since I do not have LibreOffice
installed, I cannot vouch for that.  The affected directories that I have determined to be
conflicting are: "/opt/openoffice.org/ure" and "/opt/openoffice.org3".  Both of these directories
will get overwritten by the 3.4.0 installation using the RPM binary distribution.  In addition,
the icons in "/usr/share/icons" are also overwritten.  That seems to support another user's
complaint about icons being changed.

I installed my 3.4.0 Slackware package and have several problems:

* OpenOffice 3.3.0 was, indeed, wiped out.  Just as I expected and explained above and other
users have been complaining about.  It is interesting that the directory for 2.4.x was called
"openoffice.org2.4" where 3.3.x and up is now just called "openoffice3".  What happened to
calling it "openoffice3.3" and "openoffice3.4"?  That decision most likely stopped the compatibility.

* I experienced the same problem another poster reported regarding the GLIBC version.  The
"System Requirements" state that glibc 2.5 or higher is required, but 3.4.0 expects 2.11.
 I am using 2.7.  There is also an error message about Java, but I suspect that could be cleared
up by selecting my Java RE, if the program would run, which it isn't.

I hope this helps someone on the fence about installing 3.4.0.

Girvin Herr



---------------------------------------------------------------------
To unsubscribe, e-mail: ooo-users-unsubscribe@incubator.apache.org
For additional commands, e-mail: ooo-users-help@incubator.apache.org


Mime
View raw message