incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 121230] New: Empty argument appears in the end of a formula, the argument should use a number '0' to instead.
Date Thu, 18 Oct 2012 07:30:15 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=121230

          Priority: P3
            Bug ID: 121230
          Assignee: ooo-issues@incubator.apache.org
           Summary: Empty argument appears in the end of a formula, the
                    argument should use a number '0' to instead.
          Severity: normal
        Issue Type: DEFECT
    Classification: Application
                OS: All
          Reporter: binbjguo@gmail.com
          Hardware: All
            Status: CONFIRMED
           Version: AOO 3.4.1
         Component: open-import
           Product: spreadsheet

Created attachment 79790
  --> https://issues.apache.org/ooo/attachment.cgi?id=79790&action=edit
Sample file created by MS Excel 2007

Build: 
Aoo_Trunk\Aoo_Trunk_20121012.1800

Steps:
1. New a excel document, in a cell input formula =AVERAGEA(1,2,3,) 
2. Save it and load in Spreadsheet

Defect: 
The last comma is removed, and result is different with MS Excel.

Expected:
The last comma maybe removed, but result should be the same as that in MS
Excel.

Notes:
1. It does not occur on =AVERAGE(1,2,3,).
2. It does not occur on =AVERAGEA(,1,2,3) OR =AVERAGEA(1,2, ,3).

-- 
You are receiving this mail because:
You are the assignee for the bug.

Mime
View raw message