incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 121221] New: SVG file not rendered correctly - style in grouping overrides too much?
Date Mon, 15 Oct 2012 15:27:20 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=121221

          Priority: P3
            Bug ID: 121221
          Assignee: ooo-issues@incubator.apache.org
           Summary: SVG file not rendered correctly - style in grouping
                    overrides too much?
          Severity: normal
        Issue Type: DEFECT
    Classification: Application
                OS: Windows 7
          Reporter: anders.sjostrom@gmail.com
          Hardware: PC
            Status: UNCONFIRMED
           Version: AOO 3.4.1
         Component: open-import
           Product: word processor

Created attachment 79777
  --> https://issues.apache.org/ooo/attachment.cgi?id=79777&action=edit
Wrong.svg

I have found a SVG file that is rendered differently in Open Office than in
Firefox 16 or Inkscape 0.48 etc. This is the file Wrong.svg. Note that the
rectangle should not be dashed. I use Insert->Picture-From file... to import
it.

I have removed a grouping from the file, and after that the file renders as
expected. This file is Correct.svg.

Look at the picture OpenOffice_rendering.png which demonstrates how OpenOffice
renders the files for me. In other tools both files renderes as the top one.

Look at the picture Inkscape XML Editor.png which shows the attributes present
on the grouping tag that only the troubled SVG file has. It would seem that it
is the one thing that causes the problem.

Both SVG files are created by Inkscape, saved as plain svg.

-- 
You are receiving this mail because:
You are the assignee for the bug.

Mime
View raw message