incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 121165] New: AnimatedImages : need to start the ImageSet at a given position
Date Fri, 05 Oct 2012 07:16:03 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=121165

          Priority: P3
            Bug ID: 121165
          Assignee: ooo-issues@incubator.apache.org
           Summary: AnimatedImages : need to start the ImageSet at a given
                    position
          Severity: normal
        Issue Type: DEFECT
    Classification: Code
                OS: All
          Reporter: marcelly@club-internet.fr
          Hardware: All
            Status: CONFIRMED
           Version: AOO 3.4.1
         Component: code
           Product: api

Created attachment 79735
  --> https://issues.apache.org/ooo/attachment.cgi?id=79735&action=edit
Zip containing a Writer document and 6 images

If (c.s.s.awt.XAnimatedImages) AutoRepeat is set to True, when you stop the
animation, then start it again, the animation continues from the current
displayed image. This is not optimal since in general the animation should
start at the first image. It will be problematic for long sequences.

If AutoRepeat is set to False, you can only run the entire ImageSet once, since
the last image is currently displayed.

The solution to both cases would be to have a means (method, attribute or
other) to set the starting point (an index with a default value of zero). In
long sequences it may be interesting to start at some specific positions
depending on the context.

Attachment is a zip containing AnimatedProblems.odt and 6 png images. Unzip all
in the same folder. 
Run the macro. You can start and stop animation, and use or not AutoRepeat.

-- 
You are receiving this mail because:
You are the assignee for the bug.

Mime
View raw message