incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 121165] AnimatedImages : need to start the ImageSet at a given position
Date Fri, 05 Oct 2012 10:28:43 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=121165

--- Comment #2 from Ariel Constenla-Haile <arielch@apache.org> ---
(In reply to comment #0)
> Created attachment 79735 [details]
> Zip containing a Writer document and 6 images
> 
> If (c.s.s.awt.XAnimatedImages) AutoRepeat is set to True, when you stop the
> animation, then start it again, the animation continues from the current
> displayed image. This is not optimal since in general the animation should
> start at the first image. It will be problematic for long sequences.
> 
> If AutoRepeat is set to False, you can only run the entire ImageSet once,
> since the last image is currently displayed.
> 
> The solution to both cases would be to have a means (method, attribute or
> other) to set the starting point (an index with a default value of zero). In
> long sequences it may be interesting to start at some specific positions
> depending on the context.

May be something like

start() - starts the animation from the point where it was stopped; if it is
the first time it runs, it will start from the beginning

restart() - starts from the beginning 

startAt( nPos ) - starts the animation with the sequence at the given position

-- 
You are receiving this mail because:
You are the assignee for the bug.

Mime
View raw message