incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 120368] font size with decimal values don't have a consistent approximation
Date Mon, 01 Oct 2012 01:11:15 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=120368

Andrew Dupuis <andy.1990.d@gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |andy.1990.d@gmail.com

--- Comment #1 from Andrew Dupuis <andy.1990.d@gmail.com> ---
I was able to replicate this bug on my Windows 7 machine, Intel core i7
processor. But I also found that this problem extends to other values beyond
the mentioned decimals of 999.

When I was testing this I started by entering 1000 as the font size and it was
reduced to 999.9, then I tested each single decimal value of 999.
999.3 was reduced to 999.2
999.6 to 999.5
999.8 to 999.7

After testing these values I decided to test another set of values so I chose
500 as the starting value.
500.3 was reduced to 500.2
500.4 to 500.3
500.8 to 500.7
500.9 to 500.8

Similar results were found with base font sizes as low as 10. 

This shows that setting the font size to a floating point value is imprecise
regardless of the base font size. Also certain font sizes that are recognized
by the program are not able to be directly entered in the font size field.
(500.3)

-- 
You are receiving this mail because:
You are the assignee for the bug.

Mime
View raw message