incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 118040] Word (docx) graphics not displaying at all
Date Mon, 01 Oct 2012 04:58:43 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=118040

jinesh <jjd2610@gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |jjd2610@gmail.com

--- Comment #7 from jinesh <jjd2610@gmail.com> ---
Replicated the bug successfully under the following environment &
configuration:

Operating System: Windows 7 Home Premium - service pack 1
System type: 64-bit operating system
Open Office Version: 3.4.1
Build: 9593 – Rev. 1372282

Steps and observations to encounter the bug:

1. 1st I created a .doc file using MS word 2010 having text and images. I
opened   it using ‘Openoffice.org writer’. It worked well.

2. 2nd I created a .docx file using MS word 2010 having the same content as in
step (1). I opened it using ‘Openoffice.org writer’. I again worked well.

3. 3rd I created a file using ‘OpenOffice.org writer’ from the start menu with
the same content and saved it using the extensions .doc & .odt (couldn’t save
it using .docx as open office does not give that option). I then closed and
reopened these files using open office writer, it worked well.

4. 4th attempt, now I tried to create a document (on desktop) using the
following:

Right-click -> New -> Microsoft Word Document 

But this document opens through OpenOffice.org writer. Being a MS Word Document
it saves as .docx but opens with OpenOffice.org writer. Then I created this
document using the same content as above i.e. text + images/flowcharts. Saving,
closing and reopening the document respectively gave unusual result of missing
images with only text visible and blank spaces in place of images.

5. 5th attempt, I saved the above document as .doc instead of .docx. It worked
well. Everything got displayed correctly.

6. 6th attempt, I downloaded a document from mail (.docx) still the same
problem as in step (4). But with .doc file, it works well.

This is bug is important to the customer so that they be careful while opening
the latest version of MS word file (i.e. .docx file) in OpenOffice and do not
miss out any vital information that might be contained in the form of images.

I agree with Mahjabin Alam ’s comment that if the document be saved as .doc
instead of .docx will solve the problem. To add to this, it will only be
possible when the document is created by the customer. But this simple way of
changing the extension of the document from ‘.docx’ to ‘.doc’ will not solve
the problem if it is downloaded from mail. It can only be solved if the
document is again opened using MS word and then saved as .doc, which I feel
will be redundant to have both MS Office and OpenOffice. So the bug needs to be
taken care of.

-- 
You are receiving this mail because:
You are on the CC list for the bug.
Mime
View raw message