incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 121088] Document with frames - error on PDF export
Date Sun, 23 Sep 2012 20:19:15 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=121088

Kevin <ktiller2012@my.fit.edu> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |ktiller2012@my.fit.edu

--- Comment #3 from Kevin <ktiller2012@my.fit.edu> ---
I was only partially able replicate this bug on windows as I got single-core
maxed CPU for a long time on two different machines, but it DID successfully
complete eventually.
Software (both): Windows 7 Pro 64-bit (6.1 build 7601) and AOO 3.4.1 (build
9593)
Hardware 1: Core i5 2500k, 16GB RAM
Hardware 2: Core i7 2670QM, 8GB RAM

Using a "print to pdf" program called cutePDF I was able to successfully get a
PDF, creating a simple workaround that trades massive use of system memory for
faster completion.

Pursuing the idea that the background image was at fault in causing the poor
performance I copied the file and removed the background page by page testing
each iteration. Results are below:

SUMMARY:
3 Pages of Background:
Export => >20 minutes run-time on one core
Print PDF => Obscene memory usage (capped out my 14GB free and started crushing
the HDD) and 5 minute run-time

2 Pages of Background:
Export: >10 minutes (coffee break) run-time on one core, but successful
Print PDF: 10-11GB Memory usage, 2 minute run-time

1 Page of Background:
Export => 4 Minute run-time on one core
Print PDF => 6GB Memory usage, 1 mintue run-time

0 Pages of Background:
No problems

-- 
You are receiving this mail because:
You are the assignee for the bug.

Mime
View raw message