incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 120957] Export should give same gradient for small step counts as shape in edit mode
Date Sun, 16 Sep 2012 16:32:34 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=120957

Regina Henschel <rb.henschel@t-online.de> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Assignee|rb.henschel@t-online.de     |ooo-issues@incubator.apache
                   |                            |.org

--- Comment #3 from Regina Henschel <rb.henschel@t-online.de> ---
This are my suggestions. But I have tested them only on WinXP.

Test suggestions:
In Impress, test it with linear and with axial gradient:
Insert a shape, fill it with gradient, and set the step count to a value <=64.
Copy the shape, insert it and convert it to metafile. OK?
Copy the shape, insert it and convert it to bitmap. OK? (The missing 1 pixel
right and 1 pixel bottom occurs with other fillings too.)
Switch to presentation mode. OK? (The white lines between the steps are a
problem of the presentation mode and occur in the same way using other gradient
styles like rectangle.)
Export whole slide to pdf. Open in pdf-reader. OK?
Export whole slide to flash. Open in browser. OK?
Export only shape to pure bitmap. Open with picture application. OK?
Export only shape to wmf. Open with picture application. OK?
Print slide. OK?

The code has a lot of type conversions between long and double. I'm not sure,
how to write those.

Are really min 3 in nSteps needed? I think not, but have set it according to
the old comment.

If the solution in issue 120604 implements the gradients in a different way, my
solution here has to be adapted. But I thought, I show you my solution, so you
can discuss it.

-- 
You are receiving this mail because:
You are the assignee for the bug.

Mime
View raw message