incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 120392] Impress wizard crashes when I set presentation type to automatic and pause duration zero
Date Thu, 06 Sep 2012 03:52:10 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=120392

louqle <louqingle@gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Keywords|crash                       |
             Status|UNCONFIRMED                 |CONFIRMED
                 CC|                            |louqingle@gmail.com
     Ever confirmed|0                           |1

--- Comment #4 from louqle <louqingle@gmail.com> ---
(In reply to comment #1)
> PC and Test Environment:
> OS: Microsoft Windows XP Professional (Version 2002) Service Pack 3
> CPU: Intel (R) Core (TM) 2 6600 @2.40 GHz
> RAM: 2.00 GB
> Apache Open Office 3.4.0 Win x86 AOO340m1 build; 9590 Rev 1327774
> Demo ID: TssAOOP (Test case Apache Open Office Presentation)
> Product: Presentation, Component: Formatting, Keyword: Crash, Version: AOO
> 3.4.0
> 
> Summary: The impress wizard crashes when I set presentation type to
> automatic. I have chosen the value of both duration of page and pause to
> zero under the presentation wizard and compiled the slideshow. I found that
> the escape button does not work while the slideshow is still running and
> when I tried to close the presentation by clicking right button option
> called ‘End show’; the system crashed with unexpected error. Slideshow seems
> to work fine except for zero and negative values. Similar occurrences found
> if I happen to choose a new database and run the slideshow from the
> presentation wizard. I was able reproduce the bug successfully.
> 
> Test case ID TssAOOP1: 
> 
> Entity title: Create a new presentation by selecting zero duration time for
> page and pause and run slideshow.
> 
> Pre-requisites: Download and install Apache Open Office 3.4.0 in your system
> if it does not exist.
> 
> Procedure:  
> 1.	Start Open Office org 3.4.0 
> 2.	Select product Presentation
> 3.	Choose type as ‘From Template’ under presentation wizard and click ‘Next’
> 4.	You can choose any output medium and click ‘Next’ again
> 5.	Select  presentation type as ‘Automatic’ under the presentation wizard 3
> 6.	Set values zero to both duration of page and duration of pause options
> 7.	Click ‘Create’
> 8.	Run slideshow from the top menu bar or clicking F5 key
> 9.	a)Try to stop slideshow by escape key or,
> b) Stop slideshow by clicking right button option called ‘End show’
> 
> Expected result: 
> 	Once the escape button or end show option is clicked the slideshow should
> be stopped successfully 
> 
>  Actual result: The system crashed with unexpected error message and
> recovery option.

Aoo_trunk 1376366 build on XP Sp3:
No crash for me. But I found the ESC key doesn't work here. 

> 
> Test case ID TssAOOP2: 
> 
> Entity title: Create a new presentation by selecting default duration time
> and run slideshow.
> Pre-requisites: Download and install Apache Open Office 3.4.0 in your system
> if it does not exist.
> Procedure:  
> 1.	Follow steps 1 to 4 of previous test case
> 2.	Select  presentation type as ‘Default’  under the presentation wizard 3
> 3.	Click ‘Create’
> 4.	Run slideshow from the top menu bar or clicking F5 key
> 5.	a)Try to stop slideshow by escape key or,
> b) Stop slideshow by clicking right button option called ‘End show’
> 
> Expected result: 
> 	Once the escape button or end show option is clicked the slideshow should
> be stopped successfully 
> 
> Actual result: The slideshow stopped successfully without any error.

Aoo_trunk 1376366 build on XP Sp3: work for me

> 
> Test case ID TssAOOP3: 
> 
> Entity title: Create a new presentation by selecting negative duration time
> for pause and run slideshow.
> 
> Pre-requisites: Download and install Apache Open Office 3.4.0 in your system
> if it does not exist.
> 
> Procedure:  
> 1.Follow all the steps like Test case ID TssAOOP1 except select the duration
> pause value to -1

Aoo_trunk 1376366 build on XP Sp3:
I cannot set the duration to a negative value, it will restored to 0
automatically.

> 
> Expected result: A warning message should come when try to input any
> negative value and once the escape button or end show option is clicked the
> slideshow should be stopped successfully 
> 
> Actual result: Result reproduce the bug, Impress wizard crashed.
> 
> Comment:
> I believe this bug could be considered as a priority (low or medium) issue
> as any user can choose the duration time zero without understanding what can
> be happened once the slideshow initialized. Although the slideshow page
> duration is set to 10 sec by default, if the user inputs the value to zero
> by mistake there is a definite chance the system will crash.

Above all, I confirm this bug since the ESC key doesn't work for ending show
when the duration time is set to 0

remove the keyword "crash"

-- 
You are receiving this mail because:
You are the assignee for the bug.
Mime
View raw message