incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 111292] Missing fonts in exported PDF when running -headless
Date Tue, 18 Sep 2012 12:10:19 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=111292

Maxim <maxbreyev@gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |maxbreyev@gmail.com

--- Comment #27 from Maxim <maxbreyev@gmail.com> ---
(In reply to comment #23)
> Setting the env-variable SAL_DISABLE_FC_SUBST before starting the app in non-
> headless mode results in the same exported PDF as the app in headless mode,
> because headless mode doesn't request external font substitutors. And the
> internal ones do know neither 黑体 nor SimHei (requested in the doc) nor
> WenQuanYi.
> 
> If you want SimHei to be always substituted by a member of the WenQuanYi
> family
> (if SimHei is not available) then please extend VCL.xcu accordingly.
> 
> If you want to have the full blown capacity of the non-headless app with all
> its resource requirements including all the libraries and config-files also
> needed by the non-headless version then the question has to be asked why
> bother
> with headless mode at all? Having the one window mapped is not costly.

Hi,

Can you elaborate a bit more on how I should extend Open Office configuration
to solve this particular issue? There is no VCL.xcu file.

If I understand it correctly, if the system misses some font, then it is not
substituted in headless mode. Is there a workaround for this (so OOo in
headless mode works with fonts equally to non-headless mode)?

-- 
You are receiving this mail because:
You are on the CC list for the bug.
Mime
View raw message