incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 120744] New: insert as bitmap from clipboard or convert to bitmap adds 1 pixel if anti-aliasing is used
Date Tue, 28 Aug 2012 19:28:31 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=120744

          Priority: P4
            Bug ID: 120744
          Assignee: ooo-issues@incubator.apache.org
           Summary: insert as bitmap from clipboard or convert to bitmap
                    adds 1 pixel if anti-aliasing is used
          Severity: normal
        Issue Type: DEFECT
    Classification: Application
                OS: All
          Reporter: rb.henschel@t-online.de
          Hardware: All
            Status: UNCONFIRMED
           Version: AOO350-dev
         Component: editing
           Product: drawing

1. Set the page background to blue to make the error better visible.
2. Make sure "Use Anti-Aliasing" is checked in Tools > Options > OpenOffice.org
> View.
3. Draw a rectangle and set its fill color to black and border line to
invisible.
4. Copy the rectangle to clipboard and insert it "as bitmap".

Notice the light line at top and left. If you save the picture and examine it,
you can notice, that it is a 1 pixel gray border.

Alternative:
4. On the rectangle do context menu > Convert > To bitmap.

There is no need for additional gray pixels for horizontal or vertical lines.
And if it is intended to have them because of anti-aliasing, they should be on
all four edges.

Workaround:
Uncheck "Use Anti-Aliasing" when inserting as bitmap or converting to bitmap.

-- 
You are receiving this mail because:
You are the assignee for the bug.

Mime
View raw message