incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 120576] [From Symphony]the background color from table style are lost for table in the docx file
Date Thu, 16 Aug 2012 03:03:19 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=120576

bjcheny <companycy@gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #78970|                            |review?
              Flags|                            |

--- Comment #1 from bjcheny <companycy@gmail.com> ---
Created attachment 78970
  --> https://issues.apache.org/ooo/attachment.cgi?id=78970&action=edit
patch for i120576 to fix background color in table style in docx

Patch for i120576 to fix background color in table style in docx.

It is based on the knowledge of background color from wiki on table style as
below:
http://wiki.openoffice.org/wiki/Table_Style_in_Writerfilter

The change is composed of below parts:
1. For the w:tcPr under w:style, it's used for whole table. It should be
sprmed.
2. On how to apply different kinds of table styles, it follows the sequence
from wiki as below. That means ne/nw/se/sw table style can overwrite all other
types if existing.

wholeTable
band1Horz band2Horz
band1Vert band2Vert
firstCol lastCol
firstRow lastRow
neCell nwCell seCell swCell

3. Fix a typo for resetRowProp. It's related to all row properties.

-- 
You are receiving this mail because:
You are the assignee for the bug.

Mime
View raw message