incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 120536] New: hyperlink edit inconsistent
Date Fri, 10 Aug 2012 16:31:05 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=120536

          Priority: P3
            Bug ID: 120536
          Assignee: ooo-issues@incubator.apache.org
           Summary: hyperlink edit inconsistent
          Severity: normal
        Issue Type: DEFECT
    Classification: Application
                OS: All
          Reporter: TorrAB@Yahoo.com
          Hardware: All
            Status: UNCONFIRMED
           Version: AOO 3.4.0
         Component: editing
           Product: word processor

Created attachment 78906
  --> https://issues.apache.org/ooo/attachment.cgi?id=78906&action=edit
contains linked strings

In LinkABC.odt, CD is hyperlinked to AA via bookmark BMa. To link it to BB
instead, use one of three different procedures:
    ProcA:
StepA1: double-click CD to select it;
Step2: Insert/hyperlink/target: bookmarks: BMb/apply/close
It works.
    ProcB:
StepB1: put the cursor to the left of C, hit Shift_End to select 'CD'
and repeat Step2: it works.
    ProcC:
StepC1: put the cursor to the right of D, hit Shift_Home to select 'CD'
and repeat Step2: 'CD' is replaced with '#BMb'; it should not.
    Problem is: During Step2, the Text field in the Hyperlink dialogue
contained 'CD' during ProcA and ProcB, but was blank during ProcC. Of course,
one can re-enter 'CD' in the Text field, but that should not be necessary.
    This is a subtle bug: the behaviour depends on how the string 'CD' was
selected!

-- 
You are receiving this mail because:
You are the assignee for the bug.

Mime
View raw message