incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 120414] New: can't run VBA macros from command line
Date Mon, 30 Jul 2012 21:42:16 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=120414

          Priority: P3
            Bug ID: 120414
          Assignee: ooo-issues@incubator.apache.org
           Summary: can't run VBA macros from command line
          Severity: major
        Issue Type: DEFECT
    Classification: Application
                OS: All
          Reporter: Phillip.M.Feldman@gmail.com
          Hardware: All
            Status: UNCONFIRMED
           Version: AOO 3.4.0
         Component: programming
           Product: spreadsheet

Created attachment 78786
  --> https://issues.apache.org/ooo/attachment.cgi?id=78786&action=edit
this file contains the above macro code

I've created an .ods file containing the following VBA macro:

   REM  *****  BASIC  *****

   Sub Main
   MsgBox("Hello")
   End Sub

I'm unable to run this macro from the command line. I've tried it on three
different computers running three different operating systems (Windows XP,
Windows 7, and Redhat Linux version 5.4).  The actual command that I'm issuing
follows:

   soffice "test1.ods" "macro://test1/Standard.Module1.Main()"

If macro security is turned on, I get a message that the macro cannot run
because of my macro security level.  If I turn off macro security, issuing the
above command causes the Calc application to open but does not cause the macro
to run.

-- 
You are receiving this mail because:
You are the assignee for the bug.

Mime
View raw message