incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 120374] New: A bug, relating to the preview of the “page setup” dialog was discovered while testing the page margin variable of OOo Impress.
Date Thu, 26 Jul 2012 03:27:53 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=120374

          Priority: P3
            Bug ID: 120374
          Assignee: ooo-issues@incubator.apache.org
           Summary: A bug, relating to the preview of the “page setup”
                    dialog was discovered while testing the page margin
                    variable of OOo Impress.
          Severity: normal
        Issue Type: DEFECT
    Classification: Application
                OS: Windows 7
          Reporter: navneet.s.nagi@gmail.com
          Hardware: PC
            Status: UNCONFIRMED
           Version: AOO 3.4.0
         Component: viewing
           Product: presentation

System Information:
The system I am using has the following configuration: It is an Intel(R) Core 2
Duo CPU with a speed of 1.8 GHz. The installed memory is 3.00 GB. The operating
system is 64-bit Windows 7 professional SP1. The version of Open Office I’m
using is 3.4.0, Aoo340m1, build 9590. It is an HP 540 laptop.

Replicating the bug:
The following steps will help to replicate the bug:
1.    I turned on my computer, and ran Open Office Impress from the start menu
of my computer. 
2.    As the program launched, I selected the blank presentation option and the
main program window showed up with the default text boxes: one positioned at
the top of the page and the other (bigger than the former) positioned right
below the first text box.
3.    I went ahead and right clicked on the white space of the page and from
the menu, I selected “slide” that opened up a sub menu.
4.    From the “slide” submenu, I selected “page setup” that opened up a dialog
box with the same title.
5.    On the “page setup” dialog box, in the margins area, for the left margin
variable, I entered +999.99” as its value. As I entered the values, before
clicking “ok” I observed the preview on top-right position of the dialog box.
In the preview, I saw that the margin moved to its maximum possible location.
6.    I clicked “ok’. As expected, on the main page/slide, I saw that the
margin was situated at its maximum possible distance. 
7.    Again, I right-clicked on the white space of the page/slide, and again
reached the “page setup” dialog box, and on that dialog, for the “left margin”
cell, I saw that the values was 10.82” and looked at the preview.

Follow up tests:
I performed a follow up test for a couple of values greater than the value
specified before. I followed the same steps as provided above and got the same
results.

Observation/Result:
On the “page setup” dialog box, in the preview section, I saw that preview
margin was not present in its maximum possible position, even though the value
showed its maximum value. Even on the main page/slide, I saw that the margin
was positioned at its maximum possible position.

Customer Impact:
Such a bug could give false impressions to the users. A wrong preview totally
defeats the purpose of having a preview. One uses the preview solely to see how
the page looks before going through the hassle of opening the dialog box again
to do finer adjustments. A wrong preview will give a wrong impression of the
page, which may result in corrupting the page. This could turn out to be
serious while someone is using the program to set a margin during a high
profile board meeting. A corrupted page could result in an embarrassing
situation.

-- 
You are receiving this mail because:
You are the assignee for the bug.
Mime
View raw message