incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 120332] New: Can't upgrade 3.3 -> 3.4
Date Fri, 20 Jul 2012 17:32:23 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=120332

          Priority: P3
            Bug ID: 120332
          Assignee: ooo-issues@incubator.apache.org
           Summary: Can't upgrade 3.3 -> 3.4
          Severity: normal
        Issue Type: DEFECT
    Classification: Application
                OS: All
          Reporter: akienm@gmail.com
          Hardware: All
            Status: UNCONFIRMED
           Version: AOO 3.4.0
         Component: ui
           Product: installation

Today I downloaded 3.4. I have 3.3 installed. I can't install 3.4 it without
the 3.3 installer, which I no longer have. No, don't stop reading now because
you've already figured this out... Please read the rest. 

I downloaded 3.3 and installed it some time ago. I downloaded it to my desktop,
which is what I do with everything I'm currently working on. I use it as kind
of a to-do list. After installing it, I deleted the installer, as it was no
longer on my to-do list.

1) It was not made clear during the 3.3 install process that I would need the
3.3 installer to upgrade.

2) *having* to keep the 150M 3.3 installer around is mindboggling. I've never
encountered that before. It's a waste of disk space. 

You could mod the installer to copy out the things it will need to uninstall to
the program dir. That's what all the stuff I've worked on has done. (I'm QA
test automation developer) This would be *my* personal favorite solution.

You could also mod the code to just go download the necessary components if
needed. Have an uninstall package on the web or something. 

You could even, at the very least, explain in the installer in hard to miss
form that the current installer will be needed at uninstall time.

-- 
You are receiving this mail because:
You are the assignee for the bug.

Mime
View raw message