incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 120302] Add support for "AOO" and "Apache OpenOffice" in @since tag
Date Wed, 18 Jul 2012 03:02:24 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=120302

--- Comment #1 from Ariel Constenla-Haile <arielch@apache.org> ---
Created attachment 78672
  --> https://issues.apache.org/ooo/attachment.cgi?id=78672&action=edit
Patch to support both "AOO" and "Apache OpenOffice"

Adding support for "@since AOO" is rather simple, just add 

 SapiDocu_PE::CheckVersionSyntax_OOo(const String & i_versionPart1)
 {
     return      i_versionPart1 == "OOo"
-            OR  i_versionPart1 == "OpenOffice.org";
+            OR  i_versionPart1 == "AOO"
             OR  i_versionPart1 == "OpenOffice.org";
 }

in main/autodoc/source/parser_i/idoc/docu_pe2.cxx

Adding support for "@since Apache OpenOffice" is a bit of a hack, because it
add processing a new token if the first one is "Apache".

With the current patch both

        @since Apache OpenOffice 3.5
        @since AOO 3.5

are supported.

-- 
You are receiving this mail because:
You are on the CC list for the bug.

Mime
View raw message