incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 120170] New: Autosave loops and endlessly produces 0KB backup files when it fails to autosave
Date Tue, 03 Jul 2012 09:16:21 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=120170

          Priority: P3
            Bug ID: 120170
          Assignee: ooo-issues@incubator.apache.org
           Summary: Autosave loops and endlessly produces 0KB backup files
                    when it fails to autosave
          Severity: normal
        Issue Type: DEFECT
    Classification: Application
                OS: All
          Reporter: sc1_4@ashisuto.co.jp
          Hardware: All
            Status: UNCONFIRMED
           Version: AOO 3.4.0
         Component: save-export
           Product: spreadsheet

This is probably related to bug 69993 and other "Write error" bugs
since it is only reproducible for files that produce "Write error."

Reproduced with OOo 3.2.1, 3.3.0 and AOO 3.4.0 running on Win 7 and XP.
I will attache a bugdoc for testing.

When Autosave is ran, it fails to save a backup file with contents and
tries again and again and again, and keeps producing 0KB backup files
until the original file is closed.

Steps to reproduce:
1. Set Autosave duration to "1 min" for faster testing.
2. Kill all "soffice.bin" processes including the Quickstarter.
   Make sure no OO files are open.
   *This is important to reproduce the "Write error." Refer to the
    mentioned bug 69993 for more details on it.
3. Open below directory

For XP
C:\Documents and Settings\use name\Application
Data\OpenOffice.org\3\user\backup

For Win 7
C:\Users\user name\AppData\Roaming\OpenOffice.org\3\user/backup

4. Open the attached Bugdoc.ods and wait for the Autosave to run.
   (Enter some texts if it doesn't autosave after a minute and wait again.)
5. Go to the backup directory and see 0KB backups being produced endlessly.

The "Write error" issue seems to have been fixed in LibreOffice 3.4.

-- 
You are receiving this mail because:
You are the assignee for the bug.

Mime
View raw message