incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 120048] Add button in spell check dialog doesn't show custom dictionaries
Date Fri, 22 Jun 2012 20:56:04 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=120048

Ariel Constenla-Haile <arielch@apache.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |arielch@apache.org

--- Comment #3 from Ariel Constenla-Haile <arielch@apache.org> ---
Looking at the code in 

svx::SpellDialog::InitUserDicts()
main/cui/source/dialogs/SpellDialog.cxx

reveals that the language in the SvxLanguageBox is LANGUAGE_DONTKNOW (0x03FF)
when the PopupMenu is filled. On the other side, SwSpellPopup in
sw/source/ui/lingu/olemenu.cxx has the right language (though the code is
almost the same).

The issue is that svx::SpellDialog::InitUserDicts() is called on the
constructor (actually on void SpellDialog::Init_Impl()), but not every time
SpellDialog::UpdateBoxes_Impl() is called, as it should: 

SpellDialog::UpdateBoxes_Impl() gets the current Locale from the
SpellErrorDescription and updates the selected language accordingly calling
SetSelectedLang_Impl(). Right after this call, the user dictionaries should be
updated.

In short, InitUserDicts() is invoked too little, not reflecting the
Locale/language change.

-- 
You are receiving this mail because:
You are the assignee for the bug.

Mime
View raw message