incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 119403] New: AOO 3.4 - GridControl not refreshing after deleting rows
Date Tue, 22 May 2012 16:57:51 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=119403

          Priority: P3
            Bug ID: 119403
          Assignee: ooo-issues@incubator.apache.org
           Summary: AOO 3.4 - GridControl not refreshing after deleting
                    rows
          Severity: normal
        Issue Type: DEFECT
    Classification: Code
                OS: Windows 7
          Reporter: wolfgang-becker@online.de
          Hardware: PC
            Status: UNCONFIRMED
           Version: OOo 3.4 Beta
         Component: code
           Product: api

Created attachment 77580
  --> https://issues.apache.org/ooo/attachment.cgi?id=77580&action=edit
CALC macro to display GridContol. Buttons to add / remove rows.

I use Windows 7 and AOO 3.4.

GridControl in user-dialog is not refreshing when rows are removed with
BASIC-command "DeleteRow" within CALC-Macro. 

To check the problem see Calc-file with attached macro. Grid is only updated
after minimizing und maximizing the Window on the desktop. 

With the same macro there is no repaint problem in Libre Office 3.5.

Procedure to reproduce the bug on the attached document:
- open the attached document and push button to show the dialog,
=> dialog having a grid control with two buttons is shown
- push "AddRow" button five times,
=> 5 rows are added
- push "RemoveRow" button three times,
=> the removed 3 rows are still displayed within grid.

-- 
You are receiving this mail because:
You are the assignee for the bug.

Mime
View raw message