incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject [Bug 119402] New: css.awt.SpinningProgressControlModel do not work well
Date Tue, 22 May 2012 16:54:17 GMT

          Priority: P3
            Bug ID: 119402
           Summary: css.awt.SpinningProgressControlModel do not work well
          Severity: normal
        Issue Type: DEFECT
    Classification: Code
                OS: All
          Hardware: PC
            Status: CONFIRMED
           Version: AOO 3.4.0
         Component: code
           Product: api

Created attachment 77579
Example code to use SpinningProgressControlModel

css.awt.SpinningProgressControlModel is introduced to replace
css.awt.UnoControlThrobber and its model on 3.4. 
But it seems not work well, nothing shown for the position of the control. 
When I use css.awt.AnimatedImagesControl and css.awt.AnimatedImagesControlModel 
to show animated images, it works well. But I replace
with SpinningProgressControlModel, nothing shown.

The attached document includes the macro to use SpinningProgressControlModel. 
- Open the attached document.
- Push "push" button on the document. -> dialog shown.
- spinning control should be shown at the left top corner of the dialog ->
- spinning animation created with AnimatedImagesControlModel is shown in the
- Push "Animated" button -> shown one works well.

It seems this problem is caused by lacking of spinning images from

You are receiving this mail because:
You are the assignee for the bug.

View raw message