incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 119381] Reactivate KDE3 integration
Date Sat, 26 May 2012 01:27:01 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=119381

Ariel Constenla-Haile <arielch@apache.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|UNCONFIRMED                 |ACCEPTED
                 CC|                            |arielch@apache.org
         Issue Type|DEFECT                      |ENHANCEMENT
            Version|version58                   |current
           Assignee|uineedsconfirm@ui.openoffic |arielch@apache.org
                   |e.org                       |
            Summary|Reactivate KDE3 file        |Reactivate KDE3 integration
                   |chooser for Trinity Desktop |
                   |and openSuSE                |
     Ever confirmed|0                           |1

--- Comment #1 from Ariel Constenla-Haile <arielch@apache.org> ---
(In reply to comment #0)
> The code that allows native kde3 file dailog use with openoffice should be
> re-enabled to support Trinity Desktop (TDE) as well as openSuSE that will
> continue offering KDE3 as a supported part of its distribution with the 12.2
> release.
> 
> Libre has agreed to re-enable the KDE3 file dialog integration in its
> upcoming 3.6 release in response to request from the Trinity developer. See:
> http://lists.freedesktop.org/archives/libreoffice/2012-May/031676.html
> 
> I would like to see OO do this as well. The ability to use native file
> dialogs with OO could make the difference between users choice of OO or LO
> as the default file dialog on both has long been inadequate. 

> If TDE provided
> a patch, would you consider re-enabling the KDE3 dialog integration to
> support TDE as well as the major distros that have gone back to supporting
> that KDE3? If so I will work to provide the patch.

It all depends on two things:
* the patch is provided under the Apache License v. 2.0
* it can be built on the systems where we build the releases

It seems that enabling back KDE3 support and enabling TDE support might not be
the same thing on the system where we build (it may supply by default a KDE3
version, but not TDE). We are not building in OpenSuse, and we try that our
Linux builds work on most (still supported) Linux distributions.

Accepting the KDE3 part of the issue.
Changing the subject to include the whole KDE3 support, not only the file
picker.
Started.

-- 
You are receiving this mail because:
You are on the CC list for the bug.

Mime
View raw message