incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject DO NOT REPLY [Bug 119296] New: Problem in SVG Export: gradient appears instead of a shape
Date Sat, 28 Apr 2012 11:22:44 GMT

             Bug #: 119296
        Issue Type: DEFECT
           Summary: Problem in SVG Export: gradient appears instead of a
    Classification: Application
           Product: Drawing
           Version: AOO340-dev
          Platform: PC
        OS/Version: All
            Status: CONFIRMED
          Severity: normal
          Priority: P3
         Component: save-export

Created attachment 77500
Export to SVG from 3.3.0 and 3.4; export in 3.3.0 works much better.

OpenOffice 3.4-RC does not export the attached ODG file to SVG properly.
Regression with respect to version 3.3.0.

To reproduce:
1. Open the attached ODG file in OpenOffice 3.4-RC.
2. Export to SVG.
3. Open the exported SVG in Draw: a big gradient appears where the monument
shape was showing.

If the export in steps 1-2 is done with OpenOffice 3.3.0, the SVG file can be
imported in 3.4-RC and the problem does not appear.

It is an export problem because other programs, like Inkscape and Firefox, have
the same behavior on import (i.e., they display the SVG exported by 3.4-RC with
the error, while they display the SVG exported by 3.3.0 correctly).

[Reported by Massimiliano during Italian QA tests]

Configure bugmail:
------- You are receiving this mail because: -------
You are the assignee for the bug.

View raw message