incubator-ooo-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 119282] New: Rotated inserted bitmaps are severely displaced
Date Wed, 25 Apr 2012 04:30:25 GMT
https://issues.apache.org/ooo/show_bug.cgi?id=119282

             Bug #: 119282
        Issue Type: DEFECT
           Summary: Rotated inserted bitmaps are severely displaced
    Classification: Application
           Product: Drawing
           Version: OOO330m20
          Platform: PC
        OS/Version: All
            Status: UNCONFIRMED
          Severity: major
          Priority: P3
         Component: editing
        AssignedTo: graphicsneedsconfirm@graphics.openoffice.org
        ReportedBy: lance@arclight.net
                CC: ooo-issues@incubator.apache.org


An inserted picture (bitmap) object, when rotated, is severely displaced.

Steps to reproduce:

1. Insert | Picture | From File
2. Select a bitmap; click Open
3. In the drawing, right-click the bitmap
4. Position and Size | Rotation
5. Rotate the drawing (any value; the more the rotation, the more dramatic the
bug). It does not matter where the pivot point is.
6. Note that the picture has not rotated in place; it is displaced by at least
the size of the bitmap. Note that the object's manipulation-frame is where it
should be; it's the display of the object which is broken.

Notes:

If you print the drawing, the rotated object will be printed where displayed
(the wrong location). Same for PDF.

If you create a drawing with an earlier non-bugged version of Draw that has an
inserted bitmap, you can rotate that object in the current (bugged) version and
it will rotate correctly. It is only newly-inserted bitmaps which are bugged.

If you copy-paste a bitmap, the bug will manifest on the pasted bitmap.


My system:

WinVista Ultimate/64 SP2, fully patched
4gb memory
nVidia 460 GTX 1gb (driver 295.73)
Screen resolution 1920x1080

For what it's worth, it also occurs in LibreOffice 3.5

-- 
Configure bugmail: https://issues.apache.org/ooo/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

Mime
View raw message